Bug 447749 - switchdesk.desktop': Key file contains line '???...
switchdesk.desktop': Key file contains line '???...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 473855 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 11:43 EDT by Nerijus Baliūnas
Modified: 2008-12-13 17:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 17:09:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nerijus Baliūnas 2008-05-21 11:43:09 EDT
When I update with yum, I get:
  Updating  : banshee                      ##################### [ 57/154] 
Could not parse file '/usr/share/applications/switchdesk.desktop': Key file
contains line '????????? ?????????????' which is not a key-value pair, group, or
comment
  Updating  : virt-manager                 ##################### [ 58/154] 
Could not parse file '/usr/share/applications/switchdesk.desktop': Key file
contains line '????????? ?????????????' which is not a key-value pair, group, or
comment

It seems line Comment[ml] is broken.

# rpm -qf /usr/share/applications/switchdesk.desktop
switchdesk-gui-4.0.9-2.noarch
# rpm -V switchdesk-gui-4.0.9-2.noarch
Comment 1 Ted Powell 2008-11-27 16:50:10 EST
Problem still exists in switchdesk-gui-4.0.9-3.fc9.noarch
In this version, /usr/share/applications/switchdesk.desktop, line 102, which begins with "Comment[ml]=", contains a bogus linebreak, so the tail of the line appears as line 103. Since the characters are mostly Malayalam, the error message shows them as question marks.

I first observed the problem circa 2008-03-10. In the then-current version, the first half of the broken line was exactly 80 characters long, so in an 80-column window it was not obvious that the remainder of the line was a separate line rather than simply wrapped.

In vi, the fix is trivial:  102GJZZ
Comment 2 Ted Powell 2008-11-27 16:50:44 EST
Ted Powell
Comment 3 Jerry Amundson 2008-12-10 13:13:29 EST
*** Bug 473855 has been marked as a duplicate of this bug. ***
Comment 4 Ngo Than 2008-12-13 17:09:31 EST
it's fixed in 4.0.9-4, thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.