Bug 447811 - system-config-network produces unreliable results in handling configuration files
system-config-network produces unreliable results in handling configuration f...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-network (Show other bugs)
4.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 17:33 EDT by Drew Bentley
Modified: 2010-11-24 07:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, running the system-config-network utility may have caused some manual changes to the relevant configuration files to be lost. This error no longer occurs, and such changes are now kept as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-24 07:42:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Drew Bentley 2008-05-21 17:33:30 EDT
Description of problem: system-config-network creates default files in
/etc/sysconfig/networking/profiles/default/ but does not re-read the particular
configuration if the file is deleted from
/etc/sysconfig/networking/profiles/default/


Version-Release number of selected component (if applicable): Version
1.3.22.0.EL.4.4-1 used but all are likely affected.


How reproducible: Do not launch system-config-network. Edit your /etc/hosts file
to your own customization leaving the default 127.0.0.1 localhost.localdomain
localhost entry.

Example:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain localhost
192.168.0.100           hostname.localdomain hostname

Launch the system-config-network. Without saving, it should create
/etc/sysconfig/networking/profiles/default/hosts by copying the /etc/hosts to
this location to read in the utility.

Now delete /etc/sysconfig/networking/profiles/default/hosts and relaunch
system-config-network and you'll find that the Hosts tab will not include the
192.168.0.100 entry you made in the original /etc/hosts.


Expected results: This tool should re-read the original file (/etc/hosts) if not
present in /etc/sysconfig/networking/profiles/default/hosts, if it is deleted or
moved, preventing those that choose to use the system-config-network over hand
editing. This should also not overwrite the existing /etc/hosts or other files
it controls, leaving the actual source configurations intact when such files are
deleted and the user is presented with empty settings if such files were removed
from /etc/sysconfig/networking/profiles/default/

Basically this tool should just re-read or copy over the configurations every
time to ensure all original settings are intact, instead of having multiple
locations of configurations, where one can get overwritten because someone
chooses to use the utility over pushing out new configurations by other means.


Additional info: If you hand edit either hosts file in either location, each
gets updated which makes sense but this will fail if someone replaces /etc/hosts
with a new file not created by system-config-network, upon a reboot we found
that /etc/sysconfig/networking/profiles/default will overwrite /etc/hosts that
you created by other means, like pushing out from a central server to make
administration life easier.
Comment 2 RHEL Product and Program Management 2008-10-31 12:46:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Carlos Gili 2009-05-23 15:55:10 EDT
Hope this will help you to solve the problem, I've noticed that the network administration and configuration tool erroneously stores the IP address in the NetMask Field inside the /etc/sysconfig/networking/devices files, and it also reads the IP, not the netmask and places it in the NetMask Field in the GUI.

All the problems were solved after editing manually /etc/sysconfig/networking/devices....

:D
Comment 8 Jaromir Hradilek 2010-11-09 06:27:06 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, running the system-config-network utility may have caused some manual changes to the relevant configuration files to be lost. This error no longer occurs, and such changes are now kept as expected.
Comment 15 errata-xmlrpc 2010-11-24 07:42:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0911.html

Note You need to log in before you can comment on or make changes to this bug.