Bug 44782 - --relocate option is broken
Summary: --relocate option is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-16 17:12 UTC by twinkel_soft
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-16 17:12:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description twinkel_soft 2001-06-16 17:12:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I can't use the --relocate option with rpm

How reproducible:
Always

Steps to Reproduce:
rpm -i --relocate /opt=/opt/IBMWebAS -vv xxx.i386.rpm

Actual Results:  #debug info
D: relocating /opt/lib/xx.jar to /opt/IBMWebAS
D: relocating /opt/lib to /opt/IBMWebAS
...
D: file: /opt/IBMWebAS action: create
D: file: /opt/IBMWebAS action: create
...

Installation fails !!!

Expected Results:  #debug info
D: relocating /opt/lib/xx.jar to /opt/IBMWebAS/lib/xx.jar
D: relocating /opt/lib to /opt/IBMWebAS/lib
...
D: file: /opt/IBMWebAS/lib/xx.jar action: create
D: file: /opt/IBMWebAS/lib action: create
...

Installation fails !!!

Additional info:

Comment 1 Jeff Johnson 2001-06-16 19:13:54 UTC
Fixed in rpm-4.0.3-0.6, available from ftp://ftp.rpm.org/pub/rpm/test-4.0.3.
Please reopen this bug if that does *not* fix your problem.


Note You need to log in before you can comment on or make changes to this bug.