Bug 447858 - UnicodeDecodeError backtrace from 3.2.16
UnicodeDecodeError backtrace from 3.2.16
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 02:21 EDT by Mamoru TASAKA
Modified: 2014-01-21 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 06:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-05-22 02:21:55 EDT
Description of problem:
When I try
# yum -d9 -y upgrade --exclude=firefox\* --exclude=kazehakase\*
--exclude=kernel\* --exclude=nodoka\* --exclude=pulse\* --exclude=xulrunner\*

This ends with failure leaving backtrace:
Finished Transaction Test
Traceback (most recent call last):
  File "/usr//bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 405, in doTransaction
    errstring += '  %s\n' % descr 
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 2: ordinal
not in range(128)



Version-Release number of selected component (if applicable):
yum-3.2.16-2.fc10.noarch

How reproducible:
100%

Additional info:
Currently packages to be updated by this option is:
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 GConf2                  i386       2.22.0-9.fc10    koji              1.6 M
 GConf2-devel            i386       2.22.0-9.fc10    koji              104 k
 GConf2-gtk              i386       2.22.0-9.fc10    koji               19 k
 PyQt4                   i386       4.4.2-1.fc10     koji              2.7 M
 bluez-utils             i386       3.32-1.fc10      koji              545 k
 cairo-dock              i386       1.5.5.4-5.svn1015_trunk.fc10  koji         
    1.1 M
 cairo-dock-plug-ins     i386       1.5.5.4-5.svn1015_trunk.fc10  koji         
     13 M
 cairo-dock-themes       i386       1.5.5.4-5.svn1015_trunk.fc10  koji         
    6.6 M
 doxygen                 i386       1:1.5.6-2.fc10   koji              2.5 M
 dvipdfmx                i386       0-0.22.20080520cvs.fc10 
core-devel-domes-CACHE  372 k
 emerald                 i386       0.7.2-1.fc9      koji-9-updates    347 k
 enchant                 i386       1:1.4.2-2.fc10   koji               50 k
 enchant-aspell          i386       1:1.4.2-2.fc10   koji              8.1 k
 enchant-devel           i386       1:1.4.2-2.fc10   koji               35 k
 kdebase-workspace       i386       4.0.72-4.fc10    koji               31 M
 kdebase-workspace-libs  i386       4.0.72-4.fc10    koji              1.1 M
 ksysguardd              i386       4.0.72-4.fc10    koji               60 k
 man-pages-ja            noarch     20080515-1.fc10  koji              5.1 M
 mtr                     i386       2:0.73-1.fc10    koji               52 k
 rrdtool                 i386       1.3-0.17.rc4.fc10  koji              405 k
 ruby-aws                noarch     0.3.0-1.fc10     koji               38 k
 ruby-gettext-package    noarch     1.91.0-1.fc10    koji              100 k
 ruby-mechanize          noarch     0.7.6-1.fc10     koji               46 k
 sip                     i386       4.7.6-1.fc10     koji              228 k
 vsftpd                  i386       2.0.6-4.fc10     koji              144 k
 yum-utils               noarch     1.1.14-1.fc10    koji               59 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update      26 Package(s)         
Remove       0 Package(s)
Comment 1 Mamoru TASAKA 2008-05-23 06:46:32 EDT
With yum-3.2.16-2.fc10, currently

-----------------------------------------------
# yum -y upgrade dvipdfmx
-----------------------------------------------

surely reproduces this issue, with dvipdfm-0.13.2d-38.fc9 and
dvipdfmx-0-0.20.20071115cvs.fc9 installed and yum tries to
upgrade dvipdfmx to 0-0.22.20080520cvs.fc10.

With dvipdfm-0.13.2d-38.fc9 installed, rpm -Fvh shows
-----------------------------------------------
# find /var/cache/yum/ -name dvipdfmx\*rpm | LANG=C xargs rpm -Fvh --test
Preparing...                ########################################### [100%]
        file /usr/bin/ebb from install of dvipdfmx-0-0.22.20080520cvs.fc10.i386
conflicts with file from package dvipdfm-0.13.2d-38.fc10.i386
-----------------------------------------------

With dvipdfm forcely removed, "yum -y upgrade dvipdfmx" surely
succeeds. At this stage "yum -y install dvipdfm" reproduces the 
backtrace.
Also,
- creating a rpm which only contains zero-size /bin/ps
- trying to install the rpm by "yum --nogpgcheck localinstall"
reproduces the backtrace.

So I guess that current yum 3.2.16-2  behaves wrongly when there
is file conflicts.
Comment 2 Mamoru TASAKA 2008-06-02 14:57:40 EDT
Currently reproducible with "yum -y upgrade neon" (with koji
repo enabled):

 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 neon                    i386       0.28.2-3         koji              119 k
 neon-devel              i386       0.28.2-3         koji               91 k
Installing for dependencies:
 ca-certificates         noarch     2008-5           koji              305 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)         

Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Traceback (most recent call last):
  File "/usr//bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 405, in doTransaction
    errstring += '  %s\n' % descr 
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 2: ordinal
not in range(128)

[root@localhost ~]# find /var/cache/yum/ -name \*rpm | LANG=C xargs rpm -Uvh --test
Preparing...                ########################################### [100%]
        file /etc/pki/tls/certs/ca-bundle.crt from install of
ca-certificates-2008-5.noarch conflicts with file from package
openssl-0.9.8g-9.fc10.i686
Comment 3 Jan Hutař 2008-07-22 10:51:36 EDT
Hello,
there is a new yum in the testing which fixes some UnicodeDecodeError's - could 
you please try to reproduce with it?

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-6301

You can install by `yum upgrade yum --enablerepo=updates-testing`
Comment 4 Mamoru TASAKA 2008-07-22 14:18:50 EDT
Seemingly good on yum-3.2.17-2.fc10
Comment 5 Mamoru TASAKA 2008-07-23 12:44:40 EDT
Sorry, this bug revived... at yum-3.2.17-2.fc10

ERROR with rpm_check_debug vs depsolve:
Traceback (most recent call last):
  File "/usr//bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 243, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 195, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 404, in doTransaction
    print to_utf8(msg)
  File "/usr/lib/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 11: ordinal
not in range(128)
Comment 6 Till Maas 2008-07-28 04:33:33 EDT
I see the following traceback that disapears, when I run it with LANG=C with
"yum-3.2.17-2.fc8". Then the first download try showed:
[Errno -1] Package does not match intended download and then several 404.

Lade Pakete herunter:
(1/5): xscreensaver-base-5.06-1.fc8.i386.rpm                                   
                                                               |    0 B    
00:00     
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 243, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 195, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 381, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1107, in
downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 676, in getPackage
    cache=cache
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 654, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 398, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 933, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 868, in _retry
    cb_func(obj, *cb_args, **cb_kwargs)
  File "/usr/share/yum-cli/output.py", line 239, in failureReport
    self.logger.error('%s: %s', errobj.url, str(errobj.exception))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 65:
ordinal not in range(128)
Comment 7 James Antill 2008-08-07 15:00:04 EDT
 I think we fixed this one in 3.2.18 which is working it's way to updates-testing now.

https://admin.fedoraproject.org/updates/F9/pending/yum-3.2.18-1.fc9
Comment 8 Tim Lauridsen 2008-11-01 06:10:56 EDT
yum-3.2.19 is F9 now, so closing this one

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-7623

Note You need to log in before you can comment on or make changes to this bug.