Bug 447878 - Selinux denials concerning cupsd_t and uinput
Selinux denials concerning cupsd_t and uinput
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 05:47 EDT by Julian Sikorski
Modified: 2008-09-26 06:10 EDT (History)
0 users

See Also:
Fixed In Version: 3.3.1-93.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 06:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2008-05-22 05:47:23 EDT
Description of problem:
The following selinux denials appear whenever I start system-config-printer:

host=snowball type=AVC msg=audit(1211449186.25:36): avc: denied { write } for
pid=5168 comm="cupsd" name="uinput" dev=tmpfs ino=6539
scontext=unconfined_u:system_r:cupsd_t:s0-s0:c0.c1023
tcontext=system_u:object_r:event_device_t:s0 tclass=chr_file host=snowball
type=SYSCALL msg=audit(1211449186.25:36): arch=c000003e syscall=2 success=yes
exit=11 a0=421bb10 a1=801 a2=6279654b20726567 a3=0 items=0 ppid=1 pid=5168
auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none)
ses=1 comm="cupsd" exe="/usr/sbin/cupsd"
subj=unconfined_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null) 

and

host=snowball type=AVC msg=audit(1211449185.915:33): avc: denied { ioctl } for
pid=5168 comm="cupsd" path="/dev/input/uinput" dev=tmpfs ino=6539
scontext=unconfined_u:system_r:cupsd_t:s0-s0:c0.c1023
tcontext=system_u:object_r:event_device_t:s0 tclass=chr_file host=snowball
type=SYSCALL msg=audit(1211449185.915:33): arch=c000003e syscall=16 success=yes
exit=0 a0=b a1=5502 a2=0 a3=0 items=0 ppid=1 pid=5168 auid=500 uid=0 gid=0
euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="cupsd"
exe="/usr/sbin/cupsd" subj=unconfined_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null) 


Version-Release number of selected component (if applicable):
3.3.1-42.fc9

How reproducible:
always

Steps to Reproduce:
1. Install Fedora 9
2. set selinux to targeted mode
3. start system-config-printer
  
Actual results:
selinux denials pop up in setroubleshoot

Expected results:
nothing happens

Additional info:
I tried relabelling the whole system, but it did not help.
Comment 1 Daniel Walsh 2008-05-23 15:23:20 EDT
You can allow this for now.

# audit2allow -M mypol -l -i /var/log/audit/audit.log
# semodule -i mypol.pp

Fixed in selinux-policy-3.3.1-56.fc9.noarch
Comment 2 Julian Sikorski 2008-09-21 03:18:38 EDT
Sorry it took so long to retest, it fell out of my mind. Still present in selinux-policy-targeted-3.3.1-87.fc9.noarch:
host=snowball type=AVC msg=audit(1221981272.265:17): avc: denied { write } for pid=2450 comm="cupsd" name="uinput" dev=tmpfs ino=6542 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:event_device_t:s0 tclass=chr_file host=snowball type=SYSCALL msg=audit(1221981272.265:17): arch=c000003e syscall=2 success=yes exit=12 a0=4631b10 a1=801 a2=6279654b20726567 a3=0 items=0 ppid=1 pid=2450 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="cupsd" exe="/usr/sbin/cupsd" subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null) 

host=snowball type=AVC msg=audit(1221981272.266:18): avc: denied { ioctl } for pid=2450 comm="cupsd" path="/dev/input/uinput" dev=tmpfs ino=6542 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:event_device_t:s0 tclass=chr_file host=snowball type=SYSCALL msg=audit(1221981272.266:18): arch=c000003e syscall=16 success=yes exit=0 a0=c a1=40045564 a2=1 a3=0 items=0 ppid=1 pid=2450 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="cupsd" exe="/usr/sbin/cupsd" subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
Comment 3 Daniel Walsh 2008-09-22 14:19:20 EDT
# audit2allow -M mypol -l -i /var/log/audit/audit.log
# semodule -i mypol.pp

Fixed in selinux-policy-3.3.1-93.fc9.noarch
Comment 4 Julian Sikorski 2008-09-26 06:10:37 EDT
Seems to be fixed indeed. Cheers!

Note You need to log in before you can comment on or make changes to this bug.