Bug 447882 - RFE: add or update docs for /etc/sysconfig/network-scripts
RFE: add or update docs for /etc/sysconfig/network-scripts
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Douglas Silas
Joshua Wulf
: Documentation
: 447880 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 05:57 EDT by Murray McAllister
Modified: 2016-06-17 17:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 13:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murray McAllister 2008-05-22 05:57:23 EDT
Add documentation for the scripts in /etc/sysconfig/network-scripts/. This has
sort of been done here
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/Deployment_Guide/s1-networkscripts-control.html
,
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/Deployment_Guide/s1-networkscripts-static-routes.html,
and at
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/Deployment_Guide/s1-networkscripts-functions.html.

Maybe even describing options for the following would help (from ifcfg-ethx):

DEVICE=eth1
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=xxxxxx
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes

[I first tried to find this where all other /etc/sysconfig/[x] files were
described...]

Cheers,

Murray.
Comment 1 Murray McAllister 2008-05-22 17:51:27 EDT
*** Bug 447880 has been marked as a duplicate of this bug. ***
Comment 3 Douglas Silas 2009-09-13 15:07:10 EDT
Hi Murray,

The timeline for sorting this out is probably 5.5.

I agree with you that the networking sections, and particularly those dealing with the configuration files under /etc/sysconfig/network-scripts/ and the /etc/sysconfig/network file, could be combined and made more coherent.

Looking at the current 5.4 online docs, the ifcfg-ethX parameters do seem to be documented (though probably not comprehensively):

See:

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.4/html/Deployment_Guide/s1-networkscripts-interfaces.html

Under: "Below is a listing of the configurable parameters in an Ethernet interface configuration file"

What I would like to see is a description of how the following configuration files interact:

/etc/sysconfig/network
/etc/sysconfig/network-scripts
/etc/dhclient-ethX.conf
/etc/hosts

...especially in conjunction with system-config-network (not to mention NetworkManager).

It would, IMO, be beneficial too to add the discussion of the /etc/sysconfig/network parameters to the network configuration section, and to link to that from the /etc/sysconfig/network file description (thus moving discussion of all networking config files to the place). Would you agree with this proposal? Is this what you were thinking of, or do you have an alternative/more specific proposal?

Thanks,

Silas
Comment 4 Murray McAllister 2009-09-13 17:49:58 EDT
re comment #3, I had not seen that link before, which looks like it describes what I was looking for, sorry.

Note You need to log in before you can comment on or make changes to this bug.