Bug 447939 - Seek backend or forward -> media players crash in 0.9.11-0.2.svn20080516.fc10.i386.
Seek backend or forward -> media players crash in 0.9.11-0.2.svn20080516.fc10...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 11:20 EDT by sangu
Modified: 2008-06-27 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 14:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-05-22 11:20:54 EDT
Description of problem:
Seek backend or forward -> media players crash in 0.9.11-0.2.svn20080516.fc10.i386.
$ totem foobar.avi
[...]
E: time-smoother.c: Assertion 'x >= s->pause_time' failed at
pulsecore/time-smoother.c:423, function pa_smoother_resume(). Aborting.

Version-Release number of selected component (if applicable):
0.9.11-0.2.svn20080516.fc10

How reproducible:
always

Steps to Reproduce:
1. launch media player (like totem or rhythmbox
2. play
3. press <- or -> key 
  
Actual results:


Expected results:


Additional info:
in MPlayer
Using alsa
$ mplayer -ao alsa foobar.avi

AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
mplayer: pcm_pulse.c:274: pulse_write: Assertion `pcm->last_size >= (size *
pcm->frame_size)' failed.


MPlayer interrupted by signal 6 in module: play_audio
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

Using pulse, skip
$ mplayer -ao pulse foorbar
[..]
[mpeg4 @ 0x8791f30]frame skip 8t:  0.000   1/  1 ??% ??% ??,?% 0 0              
E: time-smoother.c: Assertion 'x >= s->pause_time' failed at
pulsecore/time-smoother.c:423, function pa_smoother_resume(). Aborting.


MPlayer interrupted by signal 6 in module: seek_audio_reset
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
Comment 1 Matěj Cepl 2008-05-30 06:12:11 EDT
Looks to me like duplicate of bug 447543
Comment 2 Lennart Poettering 2008-06-26 14:36:25 EDT
Fixed upstream. I will upload a new git snapshot into Rawhide shortly.
Comment 3 sangu 2008-06-27 12:06:53 EDT
pulseaudio-0.9.11-0.6.git20080626.fc10.i386 still has a bug.
New bug?

== change volume -> pulseaudio crash ==
1. Change volume  
2. Launch mediaplayer (like totem)
3. play media player

$ pulseaudio -vv
[...]
>D: protocol-native.c: Negotiated SHM: yes
>I: client.c: Freed 2 "Totem Movie Player"
>I: protocol-natitive.c: connection died.
> I: client.c: Created 3 "Native client (UNIX socket client)"
> D: protocol-native.c: Protocol version: remote 13, local 13
> I: protocol-native.c: Got credentials: uid=500 gid=500 success=1
> D: protocol-native.c: SHM possible: yes
> D: protocol-native.c: Negotiated SHM: yes
> I: module-alsa-sink.c: Trying resume...
> D: alsa-util.c: Maximum hw buffer size is 371 ms
> D: module-alsa-sink.c: hwbuf_unused_frames=0
> D: module-alsa-sink.c: setting avail_min=62005
> I: module-alsa-sink.c: Resumed successfully...
> D: module-alsa-sink.c: Requested to rewind 65536 bytes.
> D: module-alsa-sink.c: Mhmm, actually there is nothing to rewind.
> E: sink.c: Assertion '!s->thread_info.rewind_requested' failed at
pulsecore/sink.c:779, function pa_sink_render_into_full(). Aborting.
> D: module-suspend-on-idle.c: Sink
alsa_output.pci_1102_2_sound_card_0_alsa_playback_0 becomes idle.
> D: module-suspend-on-idle.c: Sink
alsa_output.pci_1102_2_sound_card_0_alsa_playback_0 becomes busy.
> Aborted

mplayer with alsa.
$ mplayer -vo alsa foobar.avi
[...]
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
mplayer: pcm_pulse.c:274: pulse_write: Assertion `pcm->last_size >= (size *
pcm->frame_size)' failed.

MPlayer interrupted by signal 6 in module: play_audio
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
Comment 4 sangu 2008-06-27 12:30:43 EDT
Opend new bug 453163

Note You need to log in before you can comment on or make changes to this bug.