Bug 447957 - Can't install package for another arch from gpk-application
Can't install package for another arch from gpk-application
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 446448 449376 456758 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 12:30 EDT by The Source
Modified: 2008-10-14 09:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 09:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2008-05-22 12:30:33 EDT
Description of problem:
If I have somepack.x86_64.rpm installed, I can't install somepack.i386.rpm -
gpk-application says it is already installed. I can only download and install it
manually.

Version-Release number of selected component (if applicable):
0.1.12-12.20080430.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2008-05-23 02:40:11 EDT
Right, there's some arch problems with PackageKit - I can't test this right now
as I have no 64 bit machines, but I'm ordering one today.
Comment 2 Richard Hughes 2008-06-03 09:29:24 EDT
*** Bug 446448 has been marked as a duplicate of this bug. ***
Comment 3 Richard Hughes 2008-06-03 09:29:29 EDT
*** Bug 449376 has been marked as a duplicate of this bug. ***
Comment 4 Richard Hughes 2008-06-03 09:33:58 EDT
I think I've fixed this in git master, commit
93a449d42c0467c2f4090289b5c4a2f070993260

I'll build rpms for F9 soon.
Comment 5 Matěj Cepl 2008-07-31 01:36:58 EDT
Richard, is this still valid?
Comment 6 Richard Hughes 2008-07-31 06:14:52 EDT
I'm not sure. I still don't have any 64 bit machines :-(.
Comment 7 Richard Hughes 2008-08-27 08:49:24 EDT
I've fixed this upstream, I'll try to backport the fix.
Comment 8 Richard Hughes 2008-08-27 08:49:32 EDT
*** Bug 456758 has been marked as a duplicate of this bug. ***
Comment 9 Richard Hughes 2008-08-27 09:06:38 EDT
Can you try the packages here please. Thanks.
Comment 10 Richard Hughes 2008-08-27 09:23:35 EDT
Oops: http://koji.fedoraproject.org/koji/taskinfo?taskID=788642
Comment 11 Edouard Bourguignon 2008-08-29 08:26:54 EDT
for me it's already working with PackageKit-0.2.4-4.fc9.x86_64. What do we have to test on PackageKit-0.2.4-7.fc9 from koji?

Note You need to log in before you can comment on or make changes to this bug.