Bug 447981 - Monsterz wants graphics in Windows BMP format
Monsterz wants graphics in Windows BMP format
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: monsterz (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Rafał Psota
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 14:44 EDT by Marcos Martins da Silva
Modified: 2008-05-28 19:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 19:25:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcos Martins da Silva 2008-05-22 14:44:43 EDT
Description of problem:
It does not start.

Version-Release number of selected component (if applicable):
monsterz.x86_64 0:0.7.1-3.fc9
pygame-1.7.1-16.fc9.x86_64
SDL_ttf-2.0.9-4.fc9.i386
SDL_gfx-2.0.16-5.fc9.x86_64
SDL_Pango-0.1.2-8.i386
SDL-1.2.13-3.fc9.i386
SDL_gfx-2.0.16-5.fc9.i386
SDL_net-1.2.7-4.fc9.i386
SDL_Pango-0.1.2-8.x86_64
SDL_mixer-1.2.8-8.fc9.x86_64
SDL_sound-1.0.1-9.fc9.i386
SDL_ttf-2.0.9-4.fc9.x86_64
SDL_sound-1.0.1-9.fc9.x86_64
SDL_net-1.2.7-4.fc9.x86_64
SDL-1.2.13-3.fc9.x86_64
SDL_image-1.2.6-6.fc9.x86_64
SDL_image-1.2.6-6.fc9.i386
perl-SDL-2.1.3-9.fc9.x86_64
SDL_mixer-1.2.8-8.fc9.i386
libmikmod-3.2.0-3.beta2.fc9.x86_64
libmikmod-3.2.0-3.beta2.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. start from menu or from terminal
2.
3.
  
Actual results:
A dark window just blinks and nothing more

Expected results:
the game starts

Additional info:
Running from terminal I got the following output:
/usr/share/monsterz/monsterz.py:393: RuntimeWarning: use mixer: No module named
mixer
  self.have_sound = pygame.mixer.get_init()
/usr/share/monsterz/monsterz.py: could not open data from `/usr/share/monsterz'.
Traceback (most recent call last):
  File "/usr/share/monsterz/monsterz.py", line 1994, in <module>
    main()
  File "/usr/share/monsterz/monsterz.py", line 1983, in main
    data = Data(sharedir)
  File "/usr/share/monsterz/monsterz.py", line 280, in __init__
    tiles = pygame.image.load(join(dir, 'graphics', 'tiles.png')).convert_alpha()
pygame.error: File is not a Windows BMP file
 So, after I converted all the png files to bmp files it worked until I got the
same as described on BUG #447603.
i386 machines are unaffected and monsterz starts with no problems.
Comment 1 Marcos Martins da Silva 2008-05-28 19:25:40 EDT
The new pygame package version (pygame-1.7.1-17.fc9.x86_64) solved the problem.
So It was not a bug in monsterz package.

Note You need to log in before you can comment on or make changes to this bug.