Bug 44799 - CROND very flaky
CROND very flaky
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: crontabs (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-16 18:07 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 17:35:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-16 18:07:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-ja  [en] (X11; U; FreeBSD 4.2-RELEASE i386)

Description of problem:
On a RedHat 7.1 machine, there are numberous CROND processes hung.  They
are causing the load on machines to constantly rise and rise.
Here is the output from a RH 7.1 machine not doing anything at all;

[ahnoyd@gorilla ahnoyd]$ ps -ef | grep -i cron
root     23746     1  0 Jun06 ?        00:00:00 crond
root      9273 23746  0 Jun06 ?        00:00:00 CROND
root      9276  9273  0 Jun06 ?        00:00:00 CROND
root     17311 23746  0 Jun08 ?        00:00:00 CROND
root     17312 17311  0 Jun08 ?        00:00:00 CROND
root     15252 23746  0 Jun08 ?        00:00:00 CROND
root     15255 15252  0 Jun08 ?        00:00:00 CROND
root     18884 23746  0 Jun09 ?        00:00:00 CROND
root     18885 18884  0 Jun09 ?        00:00:00 CROND
root     31017 23746  0 Jun09 ?        00:00:00 CROND
root     31021 31017  0 Jun09 ?        00:00:00 CROND
root     25681 23746  0 Jun10 ?        00:00:00 CROND
root     25684 25681  0 Jun10 ?        00:00:00 CROND
root      4764 23746  0 Jun10 ?        00:00:00 CROND
root      4765  4764  0 Jun10 ?        00:00:00 CROND
root      3864 23746  0 Jun11 ?        00:00:00 CROND
root      3865  3864  0 Jun11 ?        00:00:00 CROND
root      1672 23746  0 Jun11 ?        00:00:00 CROND
root      1675  1672  0 Jun11 ?        00:00:00 CROND
root      3365 23746  0 Jun12 ?        00:00:00 CROND
root      3366  3365  0 Jun12 ?        00:00:00 CROND
root     24830 23746  0 Jun12 ?        00:00:00 CROND
root     24831 24830  0 Jun12 ?        00:00:00 CROND
root     31445 23746  0 Jun12 ?        00:00:00 CROND
root     31446 31445  0 Jun12 ?        00:00:00 CROND
root     24848 23746  0 Jun13 ?        00:00:00 CROND
root     24849 24848  0 Jun13 ?        00:00:00 CROND
root     23832 23746  0 17:00 ?        00:00:00 CROND
root     27364 23746  0 18:01 ?        00:00:00 CROND
root     27367 27365  0 18:01 ?        00:00:00 awk -v
progname=/etc/cron.hourly

[ahnoyd@gorilla ahnoyd]$ uptime
  6:02pm  up 22 days,  4:09,  2 users,  load average: 13.00, 13.00, 13.00

What in God's Green Earth is wrong with CRON?

[root@gorilla /root]# cd /var/log
[root@gorilla log]#  cat cron |grep -i cron |egrep
'27364|23832|24849|24848|31446|31445'
May 30 14:30:00 gorilla CROND[31445]: (root) CMD (   /sbin/rmmod -as) 
Jun 12 22:30:00 gorilla CROND[31446]: (root) CMD (   /sbin/rmmod -as) 
Jun 13 15:10:00 gorilla CROND[24849]: (root) CMD (   /sbin/rmmod -as) 

How do you like those apples?


How reproducible:
Always

Steps to Reproduce:
1. Do nothing, but wait a few days
2. Log into the box
3. ps -ef|grep -i cron
	

Actual Results:  root     23746     1  0 Jun06 ?        00:00:00 crond
root      9273 23746  0 Jun06 ?        00:00:00 CROND
root      9276  9273  0 Jun06 ?        00:00:00 CROND
root     17311 23746  0 Jun08 ?        00:00:00 CROND
root     17312 17311  0 Jun08 ?        00:00:00 CROND
root     15252 23746  0 Jun08 ?        00:00:00 CROND
root     15255 15252  0 Jun08 ?        00:00:00 CROND
root     18884 23746  0 Jun09 ?        00:00:00 CROND
root     18885 18884  0 Jun09 ?        00:00:00 CROND
root     31017 23746  0 Jun09 ?        00:00:00 CROND
root     31021 31017  0 Jun09 ?        00:00:00 CROND
root     25681 23746  0 Jun10 ?        00:00:00 CROND
root     25684 25681  0 Jun10 ?        00:00:00 CROND
root      4764 23746  0 Jun10 ?        00:00:00 CROND
root      4765  4764  0 Jun10 ?        00:00:00 CROND
root      3864 23746  0 Jun11 ?        00:00:00 CROND
root      3865  3864  0 Jun11 ?        00:00:00 CROND
root      1672 23746  0 Jun11 ?        00:00:00 CROND
root      1675  1672  0 Jun11 ?        00:00:00 CROND
root      3365 23746  0 Jun12 ?        00:00:00 CROND
root      3366  3365  0 Jun12 ?        00:00:00 CROND
root     24830 23746  0 Jun12 ?        00:00:00 CROND
root     24831 24830  0 Jun12 ?        00:00:00 CROND
root     31445 23746  0 Jun12 ?        00:00:00 CROND
root     31446 31445  0 Jun12 ?        00:00:00 CROND
root     24848 23746  0 Jun13 ?        00:00:00 CROND
root     24849 24848  0 Jun13 ?        00:00:00 CROND
root     23832 23746  0 17:00 ?        00:00:00 CROND
root     27364 23746  0 18:01 ?        00:00:00 CROND
root     27367 27365  0 18:01 ?        00:00:00 awk -v
progname=/etc/cron.hourly


Expected Results:  root     23746     1  0 Jun06 ?        00:00:00 crond
root      9273 23746  0 Jun06 ?        00:00:00 CROND
root      9276  9273  0 Jun06 ?        00:00:00 CROND
root     17311 23746  0 Jun08 ?        00:00:00 CROND
root     17312 17311  0 Jun08 ?        00:00:00 CROND
root     15252 23746  0 Jun08 ?        00:00:00 CROND
root     15255 15252  0 Jun08 ?        00:00:00 CROND
root     18884 23746  0 Jun09 ?        00:00:00 CROND
root     18885 18884  0 Jun09 ?        00:00:00 CROND
root     31017 23746  0 Jun09 ?        00:00:00 CROND
root     31021 31017  0 Jun09 ?        00:00:00 CROND
root     25681 23746  0 Jun10 ?        00:00:00 CROND
root     25684 25681  0 Jun10 ?        00:00:00 CROND
root      4764 23746  0 Jun10 ?        00:00:00 CROND
root      4765  4764  0 Jun10 ?        00:00:00 CROND
root      3864 23746  0 Jun11 ?        00:00:00 CROND
root      3865  3864  0 Jun11 ?        00:00:00 CROND
root      1672 23746  0 Jun11 ?        00:00:00 CROND
root      1675  1672  0 Jun11 ?        00:00:00 CROND
root      3365 23746  0 Jun12 ?        00:00:00 CROND
root      3366  3365  0 Jun12 ?        00:00:00 CROND
root     24830 23746  0 Jun12 ?        00:00:00 CROND
root     24831 24830  0 Jun12 ?        00:00:00 CROND
root     31445 23746  0 Jun12 ?        00:00:00 CROND
root     31446 31445  0 Jun12 ?        00:00:00 CROND
root     24848 23746  0 Jun13 ?        00:00:00 CROND
root     24849 24848  0 Jun13 ?        00:00:00 CROND
root     23832 23746  0 17:00 ?        00:00:00 CROND
root     27364 23746  0 18:01 ?  00:00:00 CROND
root     27367 27365  0 18:01 ?        00:00:00 awk -v
progname=/etc/cron.hourly


Additional info:

We would really appreciate a resolution to this problem.  Or a work around,
maybe a rebuild of cron and or it dependancies?!
Comment 1 Eido Inoue 2002-02-07 16:37:40 EST
I can't reproduce the problem with your "steps to reproduce". I suspect that
something funny is going on with your modules and a hardware condition is
forcing it to wait and not give up, but I don't have enough info to know for sure.
Comment 2 Mathew Meintz 2004-10-05 12:41:54 EDT
In my environment I have a server (one of several identically
configured  IBM x305s) that experiences this problem every 29 days,
like clockwork.  If you can tell me what information you need, I'll
gather it the next time the system experiences this problem.

Note You need to log in before you can comment on or make changes to this bug.