Bug 448000 - RHEL4 qpidd --config SEGV - bug in options parsing?
RHEL4 qpidd --config SEGV - bug in options parsing?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity high
: ---
: ---
Assigned To: mick
Kim van der Riet
:
: 447582 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 16:18 EDT by Jeff Needle
Modified: 2009-05-07 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 11:06:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2008-05-22 16:18:21 EDT
Hey, Mick, hide the sharp objects before reading this one.

rhmd -t segfaults (qpidd --config=/etc/rhmd.conf)

Here's the backtrace.  Reproducible on mrg1.lab.bos.redhat.com.  Core file in /root.

#0  0x00800c12 in boost::program_options::options_description::find ()
   from /usr/lib/libboost_program_options.so.1
#1  0x0745287f in qpid::Options::parse () from /usr/lib/libqpidcommon.so.0
#2  0x0804fa04 in ?? ()
#3  0x00b8bde3 in __libc_start_main () from /lib/tls/libc.so.6
#4  0x0804dd11 in ?? ()
Comment 1 Jeff Needle 2008-05-29 15:41:28 EDT
qpidc-0.2.656926-9 and qpidd-0.2.656926-9.el4 do not exhibit this problem.
Comment 2 Jeff Needle 2008-06-02 16:03:09 EDT
*** Bug 447582 has been marked as a duplicate of this bug. ***
Comment 3 Mike Bonnet 2008-06-19 23:52:35 EDT
qpidc-0.2.667603-1.el5, qpidc-perftest-0.2.667603-1.el5, qpidd-0.2.667603-1.el5, and rhm-0.2.2153-1.el5 have been pushed to the staging repo for testing

Note You need to log in before you can comment on or make changes to this bug.