Bug 44801 - kickstart load from floppy failed
kickstart load from floppy failed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkkickstart (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-16 20:47 EDT by Pharis Tyler
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 13:37:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump from kickstart attempt (418.80 KB, text/plain)
2001-06-16 20:48 EDT, Pharis Tyler
no flags Details
cfg file requested by RH from ptyler see comments (4.86 KB, text/plain)
2001-07-03 16:27 EDT, Pharis Tyler
no flags Details
Same problem with kickstart from floppy - anaconda.dump (18.15 KB, patch)
2001-07-12 17:14 EDT, Chris Eggleston
no flags Details | Diff
Here is kickstart cfg file on floppy used (goes with prev attached anaconda dump) (4.79 KB, text/plain)
2001-07-12 17:16 EDT, Chris Eggleston
no flags Details

  None (edit)
Description Pharis Tyler 2001-06-16 20:47:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Created ks.cfg from up machine at console (no X) using mkkickstart.
used mcopy to place on floppy.
Went to install on on another box (same config) by booting from CD1 and 
entering linux ks=floppy.  Load begins and information is read from floppy 
then warning comes up asking to report the bug and write the problem to 
floppy.... which I did.  (See attachment).  Tried kickstaart 3 times with 
same result. Wrote a new kickstart file -no joy.

How reproducible:
Always

Steps to Reproduce:
1.See Description

	

Actual Results:  See Description

Expected Results:  Should have been able to complete a kickstart load.

Additional info:

If this is occuring to others... they may not be happy if kickstart does 
this to them and they are relying on it to deploy.
Comment 1 Pharis Tyler 2001-06-16 20:48:37 EDT
Created attachment 21203 [details]
anaconda dump from kickstart attempt
Comment 2 Gary 2001-07-02 16:08:59 EDT
AMEN The exact very same thing happened to me!
Comment 3 Matt Wilson 2001-07-02 16:12:19 EDT
please also attach your ks.cfg file(s)
Comment 4 Pharis Tyler 2001-07-03 16:14:55 EDT
Please see attached cfg file.
Comment 5 Pharis Tyler 2001-07-03 16:27:44 EDT
Created attachment 22612 [details]
cfg file requested by RH from ptyler see comments
Comment 6 Pharis Tyler 2001-07-03 16:32:50 EDT
humpty5.cfg file was originally called ks.cfg.  Name changed for history 
purpose and to prevent overwite.  Sorry for the multiple entries.  Had a hard 
time submitting .kfg attachment. Hey... how about a knarly RH hat for this? 
Just thought I would try!
Comment 7 Chris Eggleston 2001-07-12 17:14:10 EDT
Created attachment 23452 [details]
Same problem with kickstart from floppy - anaconda.dump
Comment 8 Chris Eggleston 2001-07-12 17:16:53 EDT
Created attachment 23453 [details]
Here is kickstart cfg file on floppy used (goes with prev attached anaconda dump)
Comment 9 Need Real Name 2001-07-18 13:37:50 EDT
I ran into the same problem using a manually created ks.cfg file but the file 
was very similar to the ones attached here. 

I was able to get it to install properly by changing my ks.cfg file as follows:

I changed the lines:

   clearpart --all
   part swap --size 256
   install

to read:

   clearpart --all
   part / --size 2000 --grow
   part swap --size 256
   part /boot --size 30
   install

These parameters for the root and boot partitions were suggested in a response 
to bug #40556. 

Comment 10 Jeremy Katz 2001-07-27 16:08:00 EDT
Yep, this is due to to missing a declaration for the root partition in the
kickstart config.  I'd recommend using ksconfig instead of mkkickstart to create
a kickstart config (it gives you a bit more control over the generated config)
and have added some sanity checking to anaconda so that at least you'll get a
more graceful failure in the future if partitions are missing.

Note You need to log in before you can comment on or make changes to this bug.