Bug 448013 - RHEL5 e2fsprogs: add ext4 support to libblkid
RHEL5 e2fsprogs: add ext4 support to libblkid
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Eric Sandeen
:
Depends On:
Blocks: 447797
  Show dependency treegraph
 
Reported: 2008-05-22 17:10 EDT by Eric Sandeen
Modified: 2009-01-20 16:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:05:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-05-22 17:10:49 EDT
For ext4 userspace support as tech preview in RHEL5, we will primarily create an
"e4fsprogs" package with updated versions of filesystem tools which will
understand ext4, in an effort to not regress the stable 1.39 version of
e2fsprogs shipped in RHEL5.

However, for some standard system shared libraries in e2fsprogs like libblkid,
we will still want to backport simple changes.

One obvious change required is to teach libblkid how to recognize ext4[dev]
filesystems, because it is used as a mount helper.
Comment 2 RHEL Product and Program Management 2008-06-02 15:57:31 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Eric Sandeen 2008-06-02 16:36:07 EDT
Built in e2fsprogs-1.39-16.el5
Comment 8 errata-xmlrpc 2009-01-20 16:05:31 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0136.html

Note You need to log in before you can comment on or make changes to this bug.