Bug 448015 - Rhythmbox D-Bus activation hangs
Rhythmbox D-Bus activation hangs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 17:48 EDT by Kamil Pawlowski
Modified: 2009-03-26 02:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 02:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Pawlowski 2008-05-22 17:48:38 EDT
Description of problem:
When I click on applet icon, rhythmbox starts, but without tray icon. So I can
only do killall rhythmbox, because i can't go to rhythmbox gui (only way is
click on tray icon). When I run player traditionally, everything seems to be ok. 

Version-Release number of selected component (if applicable):
gnome-applet-music-2.3.0-2.fc9.x86_64


How reproducible:
always
Comment 1 Peter Gordon 2008-05-22 21:43:09 EDT
Is this with the plugin method set to "Command" or "D-Bus activation"?

(Right click the applet, select the "Rhythmbox" plugin, and click the
"Configure..." button.)
Comment 2 Peter Gordon 2008-05-23 04:04:24 EDT
Ah, I think I've narrowed it down some. 

I created a new user to test this with, and (from what I could tell) with an
empty library, Rhythmbox seems to never show its main window until you click the
"Play" icon. After adding some music to it and re-logging in, it takes a few
seconds but does properly display itself.

With the setting set to "Command" activation, the RB window shows nearly
instantly after clicking applet.
Comment 3 Kamil Pawlowski 2008-05-23 08:24:04 EDT
I check this and result is: dbus activation is buggy, but command work
Comment 4 Peter Gordon 2008-05-24 14:35:29 EDT
[Re-assigning to the Rhythmbox component, and re-wording summary a bit.]

Okay, using rhythmbox-client to start RB also causes this problem (hangs while
loading, then properly shows the window after a few minutes).

At first glance this seems to be a D-Bus issue, since just running rhythmbox on
its own (e.g., "rhythmbox &" in a terminal) loads it properly.

With trying to use the client program to open Rhythmbox, the following warning
is printed to the terminal:

(rhythmbox-client:3565): Rhythmbox-WARNING **: Did not receive a reply. Possible
causes include: the remote application did not send a reply, the message bus
security policy blocked the reply, the reply timeout expired, or the network
connection was broken.

If rhythmbox is already running, this error is not shown.

This is with rhythmbox-(none):0.11.5-9.fc9.
Comment 5 Bastien Nocera 2009-03-24 09:37:09 EDT
I'm sorry, but how exactly am I supposed to reproduce this?
Comment 6 Kamil Pawlowski 2009-03-24 15:34:23 EDT
Staring rhythmbox from gnome-applet-music when dbus activation is on, but problem was solved on newest fedora release.
Comment 7 Peter Gordon 2009-03-26 02:06:09 EDT
Bastien: No reproduction possible, here. This is no longer an issue on updated Fedora 9 or 10 versions; and from my brief testing in Rawhide, it is also not affected there. :)

[Therefor, closing as CURRENTRELEASE.]

Note You need to log in before you can comment on or make changes to this bug.