Bug 44803 - no per-platform macros file for noarch target
Summary: no per-platform macros file for noarch target
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-17 02:37 UTC by James Ralston
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-17 02:37:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Ralston 2001-06-17 02:37:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9.1)
Gecko/20010608

Description of problem:
If you build an RPM on Red Had Linux 7.1 using rpm-4.0.2-8 with the
--target=noarch, certain configure macros (e.g., %_mandir, %_infodir) are
expanded to incorrect values (/usr/man instead of /usr/share/man, and
/usr/doc instead of /usr/share/doc, respectively).  This is because there
is no per-platform "macros" file for target noarch-linux.

The problem is easy to fix:

    $ cd /usr/lib/rpm
    $ mkdir noarch-redhat-linux
    $ ln -s noarch-redhat-linux noarch-linux
    $ cp -p i386-redhat-linux/macros noarch-redhat-linux/macros

Why does rpm not include the above directory structure?  It strikes me that
its absence is probably a bug; without a per-platform "macros" file for the
noarch target, certain configure macros will get expanded to the wrong
locations for Red Hat Linux 7.1.

Comment 1 Jeff Johnson 2001-06-30 16:29:46 UTC
Created /var/lib/rpm/noarch-linux per-platform configuration.
Fixed as of rpm-4.0.3-0.54.


Note You need to log in before you can comment on or make changes to this bug.