Bug 448059 - clvmd hangs when updating to RHEL5.2
clvmd hangs when updating to RHEL5.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Milan Broz
Cluster QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 04:56 EDT by David Juran
Modified: 2013-02-28 23:06 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2008-05-23 04:56:30 EDT
Description of problem:
In my two-node cluster, after updating to lvm2-cluster-2.02.32-4.el5, clmvd was
hanging which caused lvm commands (e.g. vgdisplay)to either hang or fail. 

Killing clvmd (in one case kill -9 was needed) and restarting it solved the
problem but since this update was part of the RHEL5.2 update there where a lot
of other rpm:s being updated at the same time. And one of them was the kernel
which in it's postinstall script (via mkinitrd) runs 'lvm.static vgdisplay'.
Which hangs. And a huge rpm transaction that is hanging is a scary scary thing
to behold...

Version-Release number of selected component (if applicable):
lvm2-cluster-2.02.32-4.el5

How reproducible:
Every time

Steps to Reproduce:
1. Install RHEL5.1
2. Configure a cluster with clustered VG(s)
2. yum upgrade lvm2-cluster
3. vgdisplay
  
Additional info:
Comment 3 RHEL Product and Program Management 2008-06-25 11:03:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2008-06-25 11:39:31 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 Christine Caulfield 2008-06-26 04:14:47 EDT
It looks to me that the patch for bz#435491 comment 50 is not included in RHEL5
Comment 11 Milan Broz 2008-07-03 05:37:58 EDT
In CVS in version lvm2-cluster-2.02.39-1.el5.
Comment 14 errata-xmlrpc 2009-01-20 15:55:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0100.html

Note You need to log in before you can comment on or make changes to this bug.