Bug 448073 - Logins don't work
Logins don't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 06:43 EDT by The Source
Modified: 2008-05-26 16:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 16:26:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Samba config (9.56 KB, application/octet-stream)
2008-05-23 06:43 EDT, The Source
no flags Details
log file (131.92 KB, application/octet-stream)
2008-05-26 03:19 EDT, The Source
no flags Details

  None (edit)
Description The Source 2008-05-23 06:43:23 EDT
Description of problem:
Samba server denies access even if login and password are correct. Attaching my
smb.conf

Version-Release number of selected component (if applicable):
3.2.0-1.pre3.9.fc9.i386

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 The Source 2008-05-23 06:43:23 EDT
Created attachment 306477 [details]
Samba config
Comment 2 Simo Sorce 2008-05-23 12:54:17 EDT
please raise the log level to 10 and provide the log file with the access denied
error.
Comment 3 The Source 2008-05-26 03:19:24 EDT
Created attachment 306652 [details]
log file
Comment 4 The Source 2008-05-26 03:22:21 EDT
Here you go. It looks like samba can't find specified user in database, but I
added such user with system-config-samba. Also note, that I from my PC can view
my own shares: guest account is enabled. Password is only required for one
share. But from other PC I get password input window even for server root -
guest account does not work.
Comment 5 Simo Sorce 2008-05-26 11:47:07 EDT
I am not sure why you try with usernames like ABORT or maxguest, they do not
exist in your samba passwor ddatabase.
Guest access work, if it doesn't from remote clients I'd look into the firewall.

The user thesource exist but the password you provide is wrong, have you given
the user a password with 'smbpasswd thesource' ?

Unless there is some other evidence I'd close this as not a bug.
Comment 6 The Source 2008-05-26 12:40:46 EDT
Ok, maxguest user MUST exist! It is windows username for linux user thesource -
I created it with system-config-samba. And password I typed creating this user
is also maxguest - I checked several times! If it is not samba bug than perhaps
system-config-samba one?
Comment 7 Simo Sorce 2008-05-26 13:04:36 EDT
what does 'pdbedit -L' return ?
Comment 8 The Source 2008-05-26 13:33:45 EDT
thesource:500:The Source

Oops. But windows user name for thesource on my home pc (set with
system-config-samba) as OvcaUser! 'The Source' is the full name of this user
configured after fedora installation, not for samba.
Comment 9 The Source 2008-05-26 13:36:57 EDT
Aha. Entering 'thesource' and correct password works. Looks like samba wants
linux username, not windows one. Wasn't so in Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.