Bug 448090 - radeon driver isn't working for "ATI Technologies Inc Radeon Xpress 1250"
radeon driver isn't working for "ATI Technologies Inc Radeon Xpress 1250"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 09:15 EDT by Daniel Rindt
Modified: 2009-07-14 13:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg conf directly after Fedora installation (1.86 KB, application/octet-stream)
2008-06-10 11:56 EDT, renke
no flags Details
Xorg-log directly after installation (13.92 KB, text/plain)
2008-06-10 11:56 EDT, renke
no flags Details
xorg-log with xorg-x11-drv-radeonhd (16.22 KB, text/plain)
2008-06-10 11:57 EDT, renke
no flags Details
xorg.conf with xorg-x11-drv-radeonhd (2.32 KB, application/octet-stream)
2008-06-10 11:57 EDT, renke
no flags Details
xorg.conf with testing xorg-x11-drv-ati (4.32 KB, application/octet-stream)
2008-06-11 11:59 EDT, renke
no flags Details
xorg-log with testing xorg-x11-drv-ati (28.68 KB, text/plain)
2008-06-11 12:00 EDT, renke
no flags Details
x log and conf from anaconda run (4.59 KB, application/zip)
2008-06-18 13:34 EDT, renke
no flags Details
x log and conf from Xorg -config run (13.35 KB, application/zip)
2008-06-18 13:34 EDT, renke
no flags Details

  None (edit)
Description Daniel Rindt 2008-05-23 09:15:26 EDT
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.8.0-14.fc9

How reproducible:
just install F9 and try to run rhgb or xorg. details about my card:
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Xpress 1250
(prog-if 00 [VGA controller])
        Subsystem: Samsung Electronics Co Ltd Unknown device c034
        Flags: bus master, fast devsel, latency 64, IRQ 19
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, non-prefetchable) [size=64K]
        I/O ports at 9000 [size=256]
        Capabilities: [50] Power Management version 2
        Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-


Steps to Reproduce:
1.just install F9 and try to run rhgb or xorg
2.
3.
  
Actual results:
the xorg log says that no known card is found

Expected results:
they should found my card and use it

Additional info:
xorg developers told me that in this version this card should work, but here it
doesn't.
Comment 1 Daniel Rindt 2008-06-03 16:36:58 EDT
Anaconda doesn't recognize properly the card by try starting X. It tries then
vesa, but thats not working with this card. The last step is fallback to
textmode. how can i copy the Xorg.0.log for you to get you the requested
information?
Comment 2 Matěj Cepl 2008-06-04 09:11:13 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 renke 2008-06-10 11:56:05 EDT
Created attachment 308831 [details]
xorg conf directly after Fedora installation
Comment 4 renke 2008-06-10 11:56:40 EDT
Created attachment 308832 [details]
Xorg-log directly after installation
Comment 5 renke 2008-06-10 11:57:17 EDT
Created attachment 308833 [details]
xorg-log with xorg-x11-drv-radeonhd
Comment 6 renke 2008-06-10 11:57:42 EDT
Created attachment 308834 [details]
xorg.conf with xorg-x11-drv-radeonhd
Comment 7 renke 2008-06-10 12:00:00 EDT
I attached the requested logs (xorg.conf and xorg-log after running "Xorg
-configure"). 

I mentioned that I can use X when I install the radeonhd-driver, is this a bug
in anaconda or is it possible to run the Fedora setup explicitly with this driver?
Comment 8 Dave Airlie 2008-06-10 17:30:44 EDT
can you upgrade to the xorg driver in updates-testing?

yum --enablerepo=updates-testing install xorg-x11-drv-ati

Comment 9 renke 2008-06-11 11:59:52 EDT
Created attachment 308952 [details]
xorg.conf with testing xorg-x11-drv-ati
Comment 10 renke 2008-06-11 12:00:26 EDT
Created attachment 308953 [details]
xorg-log with testing xorg-x11-drv-ati
Comment 11 renke 2008-06-11 12:01:50 EDT
I erased xorg-x11-drv-radeonhd and installed xorg-x11-drv-ati-6.8.0-16.fc9.i386
from updates-testing, attached you find the xorg.conf and log.

WFM, I was able to start X with the config.
Comment 12 renke 2008-06-13 04:16:57 EDT
sorry for misusing the tracker - but how can I include the working driver in the
installation DVD?
Comment 13 Matěj Cepl 2008-06-13 16:33:41 EDT
(In reply to comment #12)
> but how can I include the working driver in the installation DVD?

don't -- install in text mode and then (before starting X at all) run yum
upgrade in text mode. BTW, changing the startup default (to start in console or
to Xorg) is done in /etc/sysconfig/init.
Comment 14 Daniel Rindt 2008-06-18 10:59:46 EDT
(In reply to comment #12)
> sorry for misusing the tracker - but how can I include the working driver in the
> installation DVD?

a resolution which is working fine is doing a vnc install. how did you get
running the card with fedora 9?
Comment 15 renke 2008-06-18 13:33:32 EDT
Daniel:

I installed Fedora text-based and just installed the driver from testing - at
least I see a graphical screen with "Xorg -configure && Xorg -config
/root/xorg.conf.new" - usable mouse and the black/white spotted test screen.

As I thought this will solve my issues with this grahic card I created a new
installation DVD based on the repo testing with revisor (see
https://bugzilla.redhat.com/show_bug.cgi?id=451359 for a version that can create
F9 media in F8)

Unfortunately this didn't worked, I also have no graphical installer (and as I
wanrs to encrypt my HDD the grahical installer is needed).

Attached you find the X* files from the anaconda run and the one's of Xorg
-config - first failed, second worked.

I am missing a point somewhere - but I don't know which one.
Comment 16 renke 2008-06-18 13:34:11 EDT
Created attachment 309767 [details]
x log and conf from anaconda run
Comment 17 renke 2008-06-18 13:34:56 EDT
Created attachment 309768 [details]
x log and conf from Xorg -config run
Comment 18 Bug Zapper 2009-06-09 21:06:49 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Bug Zapper 2009-07-14 13:30:34 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.