Bug 448158 - Nroff script attempts to use PATH commands as opposed to fully-defined ones.
Nroff script attempts to use PATH commands as opposed to fully-defined ones.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: groff (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Vcelak
Iveta Wiedermann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 16:10 EDT by Dan Mahoney
Modified: 2013-04-12 15:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: groff-1.18.1.1-13.el5
Doc Type: Bug Fix
Doc Text:
- open manual page in restricted shell environment - the manual page is not displayed or an warning message about using old character sets appears - updated nroff script to use full paths when invkoing external binaries - the manual pages can be displayed in restricted shell environment
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 09:44:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simple patch to fix. (454 bytes, patch)
2008-05-23 16:10 EDT, Dan Mahoney
no flags Details | Diff

  None (edit)
Description Dan Mahoney 2008-05-23 16:10:20 EDT
Description of problem:

nroff shell script has incomplete path information.

Version-Release number of selected component (if applicable): 

1.18.1.1

How reproducible:

The nroff shell script, a helper agent for the critical man utility, does not
have full path commands in some places.  This causes it, when used with a
restricted shell that does not have these paths in by default, to either fail to
output a manpage, or to print an erroneous error about the manpage being used in
an old character set, such as:

XXX
XXX WARNING: old character encoding and/or character set
XXX

Steps to Reproduce:
1. Install a package such as rbash (or modify your path such that you have
access to the man command but not iconv and/or mktemp).
2. run man, note erroneous results.
  
Actual results:


Expected results:


Additional info:

I am filing this as a bug because at other points in the same code, utilities
such as "iconv" are called via their full path, thus if they resided elsewhere
in the path, this would still be broken.
Comment 1 Dan Mahoney 2008-05-23 16:10:20 EDT
Created attachment 306547 [details]
Simple patch to fix.
Comment 2 RHEL Product and Program Management 2009-03-26 12:48:34 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Jan Vcelak 2011-10-06 09:14:20 EDT
Resolved in groff-1.18.1.1-12
Comment 8 Jan Vcelak 2011-10-06 09:33:41 EDT
Updated, %{?dist} was missing, groff-1.18.1.1-13.el5
Comment 9 Jan Vcelak 2011-10-12 06:41:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
- open manual page in restricted shell environment
- the manual page is not displayed or an warning message about using old character sets appears
- updated nroff script to use full paths when invkoing external binaries
- the manual pages can be displayed in restricted shell environment
Comment 11 errata-xmlrpc 2011-11-28 09:44:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1484.html

Note You need to log in before you can comment on or make changes to this bug.