Bug 448203 - Ghdl linking problem
Ghdl linking problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ghdl (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Thomas Sailer
Fedora Extras Quality Assurance
:
: 449219 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 07:47 EDT by Sergio Pascual
Modified: 2008-06-03 03:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.26-0.94svn.1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 03:31:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of ghdl -e test (358.86 KB, application/octet-stream)
2008-05-24 07:47 EDT, Sergio Pascual
no flags Details
The test program I'm compiling (148 bytes, application/octet-stream)
2008-05-24 07:48 EDT, Sergio Pascual
no flags Details

  None (edit)
Description Sergio Pascual 2008-05-24 07:47:11 EDT
Description of problem:
I'm trying to build a very simple test program and ghdl fails to link

Version-Release number of selected component (if applicable):


How reproducible:
ghdl-0.25-0.89svn.7.fc9.x86_64

Steps to Reproduce:
1. ghdl -a test.vhdl
2. ghdl -e test
3.
  
Actual results:
Linking problems

Expected results:
Links

Additional info:
In fedora 8, libgnat is a requisite of ghdl, but it is not in fedora 9
(installing ghdl doesn't push libgnat)

I attach the output of ghdl -e test
Comment 1 Sergio Pascual 2008-05-24 07:47:11 EDT
Created attachment 306576 [details]
Output of ghdl -e test
Comment 2 Sergio Pascual 2008-05-24 07:48:08 EDT
Created attachment 306577 [details]
The test program I'm compiling
Comment 3 Thomas Sailer 2008-05-24 08:59:36 EDT
Please try ghdl-0.26-0.94svn.1.fc9, this should fix the linking problem. It is
available in updates-testing, or
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-4294. Please also give it
karma. ghdl-grt still does not depend on libgnat, so for now you have to
manually install libgnat, will fix that in the next release.

Thanks!
Comment 4 Fedora Update System 2008-05-28 22:37:53 EDT
ghdl-0.26-0.94svn.1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghdl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4294
Comment 5 Chitlesh GOORAH 2008-06-01 15:15:35 EDT
*** Bug 449219 has been marked as a duplicate of this bug. ***
Comment 6 Thibault North 2008-06-01 15:35:26 EDT
gcc-gnat is also required to achieve compilation. Install it if you get this error :

/usr/bin/ld: cannot find -lgnat-4.3
[...]
ghdl:compilation error

Works for me afer that.
Comment 7 Fedora Update System 2008-06-03 03:31:48 EDT
ghdl-0.26-0.94svn.1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.