Bug 448228 - file dependencies are not resolved
file dependencies are not resolved
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 15:18 EDT by Michael Wagner
Modified: 2014-01-21 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-24 17:06:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Wagner 2008-05-24 15:18:03 EDT
Description of problem:
While apt-get is able to resolve dependencies of packages that depend on
filenames instead of packages, yum fails to resolve them (e.g. redhat-lsb with
many filename dependencies).

Version-Release number of selected component (if applicable):
3.2.16

Steps to Reproduce:
1. yum install redhat-lsb
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package redhat-lsb.i386 0:3.1-19.fc8 set to be updated
--> Processing Dependency: /usr/bin/time for package: redhat-lsb
--> Processing Dependency: /usr/bin/pax for package: redhat-lsb
--> Finished Dependency Resolution
redhat-lsb-3.1-19.fc8.i386 from fedora has depsolving problems
  --> Missing Dependency: /usr/bin/pax is needed by package
redhat-lsb-3.1-19.fc8.i386 (fedora)
redhat-lsb-3.1-19.fc8.i386 from fedora has depsolving problems
  --> Missing Dependency: /usr/bin/time is needed by package
redhat-lsb-3.1-19.fc8.i386 (fedora)
Error: Missing Dependency: /usr/bin/pax is needed by package
redhat-lsb-3.1-19.fc8.i386 (fedora)
Error: Missing Dependency: /usr/bin/time is needed by package
redhat-lsb-3.1-19.fc8.i386 (fedora)

Additional info:
If required, I can attach additional debug information (yum -d 10).
Comment 1 Michael Wagner 2008-05-24 17:06:43 EDT
Stupid, stupid. Forgot to update to release 2. 

Sorry for the inconvenience.

Note You need to log in before you can comment on or make changes to this bug.