Bug 448232 - Low quality graphics with Neomagic driver
Low quality graphics with Neomagic driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-neomagic (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 15:35 EDT by Wojciech Kazubski
Modified: 2018-04-11 03:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.4.99.902-3.20080612
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-18 16:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X configuration file (2.76 KB, text/plain)
2008-05-27 20:43 EDT, Wojciech Kazubski
no flags Details
X windows log when using the configfile (26.93 KB, text/plain)
2008-05-27 20:44 EDT, Wojciech Kazubski
no flags Details
X windows log without using configuration file (30.13 KB, text/plain)
2008-05-27 20:46 EDT, Wojciech Kazubski
no flags Details

  None (edit)
Description Wojciech Kazubski 2008-05-24 15:35:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/4.0; Linux) KHTML/4.0.4 (like Gecko) Fedora/4.0.4-4.fc9

Description of problem:
After installing Fedora 9 on IBM Thinkpad 600X laptop, the graphic qality of some
items is low. Only bitmaps (wallpaper and icons) are displayed with reasonable
color resolution (and good quality). All other graphics are displayed with very
low color resolution, like 8 bit per pixel, and visible dithering. The same
happens on two machines, one upgraded from FC5 and one with fresh install.
The chipset is reported by lspci as Neomagic Corporation NM2360 [MagicMedia
256ZX]

I tried to downgrade xorg driver to the one from Fedora 8, the graphics qality
improves but X-es crash soon.

Version-Release number of selected component (if applicable):
xorg-x11-drv-neomagic-1.2.0-1.fc9

How reproducible:
Always


Steps to Reproduce:
1. Take IBM Thinkpad 600X laptop
2. Install Fedora 9 with KDE
3. Run the machine, login as any user and watch the result

Actual Results:
Low quality graphics (except wallpapers and icons), visible dithering, clock  it
lower right corner not visible (but responds to mouse clicking)

Expected Results:
all items displayed with 16bpp quality

Additional info:
Comment 1 Wojciech Kazubski 2008-05-25 14:36:33 EDT
I've just tested latest version 1.2.1 from Xorg. There are still the same
problems with KDE but there is some improvement since GTK apps are working again
(with 1.2.0 they crashed imediately with a message indicating missing font or
color).
Comment 2 Matěj Cepl 2008-05-26 10:49:18 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Wojciech Kazubski 2008-05-27 20:43:19 EDT
Created attachment 306866 [details]
X configuration file
Comment 4 Wojciech Kazubski 2008-05-27 20:44:39 EDT
Created attachment 306867 [details]
X windows log when using the configfile
Comment 5 Wojciech Kazubski 2008-05-27 20:46:06 EDT
Created attachment 306868 [details]
X windows log without using configuration file
Comment 6 Glen Gray 2008-05-29 11:24:43 EDT
I'd like to add my vote to this issue. I've just had to replace F9 with Xubuntu as the graphics 
performance on my NM2380 was too poor. I didn't see the same level of issues as mentioned above, 
but similar.

1) The hw cursor no longer worked and appeard as a corrupt square. Setting the SWCursor option 
resolved the issue, but this wasn't required on previous Fedora releases and isn't required on the 
Ubuntu Xorg 7.3 install from Hardy

2) Graphics acceleration seemed to be turned off even though Xaa was reported as being enabled in the 
xorg log file. Scrolling down a webpage resulted in really bad clipping. Scrolling the same page under a 
hardy installation shows nice smooth scrolling.


Comment 7 Glen Gray 2008-05-29 11:26:15 EDT
One more thing I forgot to include

3) In the Gnome-terminal, the console fonts looked terrible and where obviously not AA. Changing font 
settings had no effect.
Comment 8 Matěj Cepl 2008-05-30 07:22:47 EDT
(In reply to comment #6)
> resolved the issue, but this wasn't required on previous Fedora releases and
> isn't required on the Ubuntu Xorg 7.3 install from Hardy

Yes, *ubuntu has the same older Xorg version as F8 had. So comparison with Hardy
has no meaning here.

> 2) Graphics acceleration seemed to be turned off even though Xaa was reported
> as being enabled in the xorg log file. Scrolling down a webpage resulted in
really bad clipping.

Can we get output of this command?

glxinfo |egrep -i '(dir|dri)'

please?

Thank you.
Comment 9 Wojciech Kazubski 2008-06-05 18:53:49 EDT
[wk@sekwoja ~]$ glxinfo |egrep -i '(dir|dri)'
direct rendering: No (If you want to find out why, try setting
LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
[wk@sekwoja ~]$
Comment 10 Matěj Cepl 2008-06-06 04:56:31 EDT
Sorry, that WAS correct.
Comment 11 Wojciech Kazubski 2008-06-17 20:35:56 EDT
It seems that the recent update of xorg-x11-server cured the problem. Now the
graphic on my Thinkpad 600X is working fine again, even in 24 bit color depth.
I use version 1.4.99.902-3.20080612 of xorg-x11-serverxorg-x11-server.

The bug can be closed, if noone opposes.
Comment 12 Matěj Cepl 2008-06-18 16:56:58 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.