Bug 448241 - pulseaudio fails to start with pthread mutex assertion
pulseaudio fails to start with pthread mutex assertion
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 17:13 EDT by Michael Hampton
Modified: 2008-05-26 17:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 17:20:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hampton 2008-05-24 17:13:07 EDT
Description of problem:
pulseaudio fails to start, thus the system has no sound. When starting it
manually I get:

error@roam ~ $ pulseaudio
N: main.c: Called SUID root and real-time/high-priority scheduling was requested
in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us
priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate
PolicyKit priviliges, or become a member of 'pulse-rt', or increase the
RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
E: mutex-posix.c: Assertion 'pthread_mutex_unlock(&m->mutex) == 0' failed at
pulsecore/mutex-posix.c:98, function pa_mutex_unlock(). Aborting.
Aborted

Version-Release number of selected component (if applicable):
pulseaudio-0.9.10-1.fc9.x86_64
glibc-2.8-3.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot system.
  
Actual results:
pulseaudio fails to start.

Expected results:
pulseaudio should start normally.

Additional info:
pulseaudio worked fine at initial install; however, due to another bug I needed
to disable SELinux. Since then pulseaudio has not worked at all.
Comment 1 Lennart Poettering 2008-05-26 15:25:10 EDT
Hmm, do you have some old libtool or libltdl version lying around? This smells a
lot like an old bug in libtool/libltdl we fixed months ago, way before f9.

Please provide a full backtrace.
Comment 2 Michael Hampton 2008-05-26 17:20:58 EDT
You're right. There was an old copy of libltdl.so.3.1.4 in /usr/local/lib. I
have no idea how it got there. pulseaudio is working properly now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.