Bug 448251 - Starting disk encryption - [FAILED]
Starting disk encryption - [FAILED]
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 20:50 EDT by Kai Engert (:kaie)
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 16:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2008-05-24 20:50:08 EDT
I had installed my laptop with Fedora 9 preview.
/boot : plain ext3
/     : plain ext3
/home : disk encryption on top of software raid 1
        /dev/md0 -> /dev/mapper/luks-md0

tmp and swap also live on crypted partitions, using random keys

/etc/crypttab:
luks-md1                /dev/md1        none
luks-md0                /dev/md0        none
tmpcrypt                /dev/sda8       /dev/urandom tmp
swapcrypt               /dev/sda7       /dev/urandom swap


I have frequently updated my system using yum.

During startup, in the past, as expected, the init scripts asked me to enter my
password for the encrypted partition.


Today, when I started my computer, I no longer get prompted for the password.
The init scripts try multiple times (2 or 3) to start disk encryption, but I
always get a red [FAILED].

Is there a way for me to trace where exactly it is failing?
Or should I add "echo" statements to /etc/rc.sysinit ?
Please let me know if you have ideas how I could help to track this down.

Note, I have not made changes to my system scripts, nothing I'm aware of
(besides adding a hdparm command to /etc/rc.local ).


FWIW, I have changed my /etc/fstab and specified "noauto" for /home.
Once the system is up, I am able to manually run "cryptsetup luksOpen" and mount
/home fine.
Comment 1 Kai Engert (:kaie) 2008-05-24 20:52:41 EDT
note that picking older kernels for boot does not help.

My system is up to date, according to yum.
Comment 2 Kai Engert (:kaie) 2008-05-25 08:42:21 EDT
This seems to be a random behavior.

I had repeatedly tried, and always got the reported behavior (yesterday).

But today, it works as expected!
Comment 3 Bill Nottingham 2008-05-27 11:07:08 EDT
Is it just /home that has issues?
Comment 4 Kai Engert (:kaie) 2008-05-27 12:45:01 EDT
Both /home and my separate /extra partition (luks-md0 and luks-md1) have the
problem.

Either both work, or both don't work.

/ is a plain partition (no raid, no encryption)
Comment 5 Bill Nottingham 2008-05-27 13:08:03 EDT
Is the RAID itself being set up properly in this case?
Comment 6 Bill Nottingham 2008-05-27 13:09:27 EDT
Also, what happens if you add in:
12af846675bf3b89693d81e750a4ad86f1393130
d30e73c36dd761e853ceccc968d85daaaf85f619
and
b661d6b395f6a84813f81ae8dae2f200a792d2f5

from http://git.fedorahosted.org/git/initscripts.git?
Comment 7 Kai Engert (:kaie) 2008-05-27 13:13:01 EDT
(In reply to comment #5)
> Is the RAID itself being set up properly in this case?

Yes. When it drops me to the emergency shell, the md arrays have been started.

Also, after I added "noauto" to initscripts, as soon as the system allows me to
log in, the RAID arrays are there, too. "cryptsetup luksOpen" and "mount" is all
I need to do.

Comment 8 Kai Engert (:kaie) 2008-05-27 15:44:27 EDT
(In reply to comment #6)
> Also, what happens if you add in:
> 12af846675bf3b89693d81e750a4ad86f1393130
> d30e73c36dd761e853ceccc968d85daaaf85f619
> and
> b661d6b395f6a84813f81ae8dae2f200a792d2f5
> 
> from http://git.fedorahosted.org/git/initscripts.git?

I've prepared a rc.sysinit file and saved it locally.
As soon as the problem shows up again, I'll test your modified rc.sysinit.


Question: Should I have been able to paste your hashes into some search field on
that web page? That didn't give me results. I happened to find your 3 commits by
mousing over some links and comparing.
Comment 9 Bill Nottingham 2008-05-27 15:49:17 EDT
No, probably not. Sorry about that, probably should have just generated a patch.

I'm wondering if it's a timing issue with the RAID startup, but I'm not sure why
that would be the case.
Comment 10 Kai Engert (:kaie) 2008-07-18 16:00:58 EDT
I have never again ran into this issue.

Resolving as worksforme.

Note You need to log in before you can comment on or make changes to this bug.