Bug 448270 - Please drop or update the pulseaudio hack
Please drop or update the pulseaudio hack
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 04:35 EDT by Julian Sikorski
Modified: 2008-12-17 11:23 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.2.13-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 11:23:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2008-05-25 04:35:56 EDT
Description of problem:
Despite the fact that the updated PulseAudio driver (bug #439847) has been
merged to SDL, the hack (bug #343911) still directs to esd in case
alsa-plugins-pulseaudio is installed. This should either be changed to direct to
pulse, or even better the audio driver preference should be changed so that
pulse driver is preferred to alsa. The reason for the latter is that one may run
pulseaudio without alsa-plugins-pulseaudio installed. Currently, in such
situation there are two possibilities:
1. If the audio device is free, SDL uses alsa directly
2. If it is not, it uses the SDL driver
As you can see, the pulseaudio driver is never used.

Version-Release number of selected component (if applicable):
1.2.13-3.fc9

How reproducible:
always
Comment 1 Michel Alexandre Salim 2008-07-20 22:47:35 EDT
Ping.

On Fedora, both of the main desktops (and XFce too?) starts pulseaudio by
default, so yes, changing the override to pulse would be the minimal solution.
Would be nice to get it in before the Fedora 10 alpha freeze.

Note You need to log in before you can comment on or make changes to this bug.