Bug 448271 - login manager always shows a user list.
login manager always shows a user list.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 04:54 EDT by kb
Modified: 2018-04-11 06:26 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 18:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kb 2008-05-25 04:54:51 EDT
(FYI. i do not know the exact component that handles the login manager).



Description of problem:
The login manager always shows a few users in the user list, even after
configuring the login manager from KDE4 to not show users.

The login manager should never give away information about users on the system.


Version-Release number of selected component (if applicable):
fedora 9, fully updated, with kde4.


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

/usr/share/config/kdm/kdmrc contains:



[General]
ConfigVersion=2.3
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
PidFile=/var/run/kdm.pid
ReserveServers=:1,:2,:3
ServerVTs=-7
StaticServers=:0

[Shutdown]
BootManager=None
HaltCmd=/sbin/poweroff
RebootCmd=/sbin/reboot

[X-*-Core]
AllowShutdown=Root
AutoReLogin=false
ClientLogFile=.xsession-errors-%d
Resources=/etc/X11/xdm/Xresources
Session=/etc/kde/kdm/Xsession
SessionsDirs=/usr/share/xsessions,/usr/share/apps/kdm/sessions,/etc/X11/dm/sessions
Setup=/etc/X11/xdm/Xsetup_0

[X-*-Greeter]
AntiAliasing=true
BackgroundCfg=/etc/kde/kdm/backgroundrc
ColorScheme=Norway
EchoPasswd=true
FaceSource=PreferUser
FailFont=Abyssinica SIL,12,-1,5,50,0,0,0,0,0
FocusPasswd=true
ForgingSeed=1108476160
GUIStyle=Oxygen
GreetFont=Abyssinica SIL,16,-1,5,50,0,0,0,0,0
GreetString=Fedora 9 (Sulphur)
GreeterPos=50,50
HiddenUsers=root
Language=en_US
LogoArea=Logo
LogoPixmap=/usr/share/icons/hicolor/96x96/apps/fedora-logo-icon.png
MaxShowUID=65530
MinShowUID=500
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Abyssinica SIL,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/kde4/apps/kdm/themes/FedoraWaves
UseBackground=true
UseTheme=false
UserCompletion=false
UserList=false

[X-:*-Core]
AllowShutdown=All
NoPassEnable=false
NoPassUsers=
ServerArgsLocal=-br -nolisten tcp
ServerTimeout=30
TerminateServer=true

[X-:*-Greeter]
DefaultUser=
FocusPasswd=true
LoginMode=DefaultLocal
PreselectUser=None

[X-:0-Core]
AutoLoginEnable=false
AutoLoginLocked=false
AutoLoginUser=

[Xdmcp]
Enable=false
Willing=/etc/X11/xdm/Xwilling
Xaccess=/etc/X11/xdm/Xaccess
Comment 1 Matěj Cepl 2008-05-26 06:34:25 EDT
Either it is bug in kdm (if it is actually used), or it is not a bug at all --
no-one expects KDE being able to configure GDM. Reassigning to KDE folks.
Comment 2 Kevin Kofler 2008-05-26 06:43:00 EDT
Does your login manager look like this?
http://fedoraproject.org/wiki/Tours/Fedora9/018_Login_Screen
If so, that's GDM, not KDM.
Comment 3 Steven M. Parrish 2008-07-09 18:40:13 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.