Bug 448279 - Segfaulting applications/services during upgrade of glibc
Segfaulting applications/services during upgrade of glibc
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 07:21 EDT by Robert Scheck
Modified: 2008-08-02 23:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-02 23:31:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-05-25 07:21:01 EDT
Description of problem:
When upgrading from glibc-2.8-3 to glibc-2.8.90-4, I saw several segfaulting 
applications and services - this is very worse.

May 24 18:24:50 tux kernel: smartctl[23022]: segfault at 0 ip 00000000 sp 
bfa6df14 error 4 in ld-2.8.90.so[110000+20000]
May 24 18:24:50 tux kernel: ps[23024]: segfault at 0 ip 00000000 sp bfd768a0 
error 4 in ld-2.8.90.so[110000+20000]
May 24 18:24:50 tux kernel: df[23023]: segfault at 0 ip 00000000 sp bf99e940 
error 4 in ld-2.8.90.so[110000+20000]
May 24 18:24:55 tux init: Re-executing /sbin/init

Version-Release number of selected component (if applicable):
glibc-2.8-3
glibc-2.8.90-4

How reproducible:
Seems to be every time when upgrading from glibc-2.8-3 to glibc-2.8.90-4.

Actual results:
Segfaulting applications/services during upgrade of glibc

Expected results:
No segfaulting applications/services during upgrade of glibc like in the past
Comment 1 Ulrich Drepper 2008-08-02 23:31:48 EDT
I cannot imagine what happens.  There hasn't been any other report like this, nor is there any change explaining this.  I doubt this has anything to do with glibc.  Might be something in the kernel where pages are incorrectly replaced.

Anyway, I'm closing the bug since you most likely cannot reproduce this and there is absolutely not enough information (there is really no information at all).

We'll remember this if and when there is a similar report.

Note You need to log in before you can comment on or make changes to this bug.