Bug 448282 - Can start (or use) equalizer in banshee-0.9x.y
Can start (or use) equalizer in banshee-0.9x.y
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Nigel Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 08:43 EDT by Jens Lautenbacher
Modified: 2008-06-10 20:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 20:10:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Lautenbacher 2008-05-25 08:43:46 EDT
Description of problem:

The new banshee features a software euqalizer, it is also visible 
as an entry in the menu bar (under "View"), but greyed out.

Version-Release number of selected component (if applicable): banshee-0.99.x

Expected results: equalizer should work
Comment 1 Nigel Jones 2008-05-26 05:24:24 EDT
Hi Jens,

Just acknowledging your report, I won't have an opportunity to attempt reproducing the bug for another 
day, but in the mean time, is this with banshee 0.99.1 or 0.99.2? (rpm -qi banshee).

I've put 0.99.2 in as an update for Fedora 9 already, but this might take a couple of days to appear in 
updates-testing.

Thanks!
Comment 2 Jens Lautenbacher 2008-05-26 05:31:55 EDT
I'm currently running it with 0.99.2 (from koji), but 0.99.1 wasn't different AFAIK.

Comment 3 Nigel Jones 2008-05-26 09:16:05 EDT
(In reply to comment #2)
> I'm currently running it with 0.99.2 (from koji), but 0.99.1 wasn't different AFAIK.
Thank you for that, I just attempted this on my rawhide box and sure enough I have the same problem, I'll 
try to get to the bottom of this in the next couple of days.
Comment 4 Nigel Jones 2008-05-27 08:34:00 EDT
(In reply to comment #0)
> Description of problem:
> 
> The new banshee features a software euqalizer, it is also visible 
> as an entry in the menu bar (under "View"), but greyed out.
> 
> Version-Release number of selected component (if applicable): banshee-0.99.x
> 
> Expected results: equalizer should work

Hi, I did a bit more research and noticed that while the equaliser was
implemented in 0.98.1, it was temporarily disabled "until gstreamer pipeline
issues are resolved".

I can't see anything upstream to say that it should be re-enabled by now, I will
however check with upstream but at present I believe this is expected.
Comment 5 Nigel Jones 2008-05-27 19:04:30 EDT
This bug was intentional upstream (gstreamer issues) you should have equalised
music to your ears for the 0.99.3 release (it got reenabled the first commit
after 0.99.2 release.

Closing bug
Comment 6 Jens Lautenbacher 2008-05-31 19:37:48 EDT
still not working with 0.99.3, but it seems as if it _should_ work upstream,
because looking at the "24 bugs fixed since 0.99.2" there is bug no. 535224
(bugzilla.gnome.org), which talks about some bug with the equalizer (but it
seems as if it was working generally...)
Comment 7 Nigel Jones 2008-06-01 00:22:58 EDT
(In reply to comment #6)
> still not working with 0.99.3, but it seems as if it _should_ work upstream,
> because looking at the "24 bugs fixed since 0.99.2" there is bug no. 535224
> (bugzilla.gnome.org), which talks about some bug with the equalizer (but it
> seems as if it was working generally...)

The equalizer was removed (again) for the the same reason - gstreamer issues,
I'll keep on eye on this, but there is nothing I can do.
Comment 8 Nigel Jones 2008-06-10 20:10:13 EDT
The equalizer has made a disappearance from the menus with 1.0.0, looks like
upstream will re-enable it when gstreamer is sorted.  Closing again.

No idea when the release will occur.

Note You need to log in before you can comment on or make changes to this bug.