Bug 448320 - httpd: Syntax error on line 209; culprit = mod_speedycgi Can't locate API module structure `speedy_module'
httpd: Syntax error on line 209; culprit = mod_speedycgi Can't locate API mod...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-CGI-SpeedyCGI (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 16:46 EDT by Greg Morgan
Modified: 2008-10-31 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.22-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 18:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Morgan 2008-05-25 16:46:48 EDT
Description of problem:

I filed this bug report against httpd because a "Component" entry for
mod_speedycgi was not available.  

I wanted to experiment with some of the other Apache modules.  I installed
mod_speedycgi.  The httpd daemon failed to start during boot.  A restart shows
this error report:

/etc/rc.d/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf:
Syntax error on line 1 of /etc/httpd/conf.d/speedycgi.conf: Can't locate API
module structure `speedy_module' in file /etc/httpd/modules/mod_speedycgi.so:
/etc/httpd/modules/mod_speedycgi.so: undefined symbol: speedy_module
                                                           [FAILED]
Line 209 in httpd.conf = Include conf.d/*.conf

[root@localhost modules]# ls -l  mod_speedycgi.so
-rwxr-xr-x 1 root root 52344 2008-05-04 12:52 mod_speedycgi.so
[root@localhost modules]# pwd
/etc/httpd/modules
[root@localhost modules]# 



Version-Release number of selected component (if applicable):
rpm -q --whatprovides mod_speedycgi.so
mod_speedycgi-2.22-2.fc9.i386

How reproducible:
The problem appears as long as speedycgi.conf is present in the conf.d directory.

Steps to Reproduce:
1. yum install mod* or yum install mod_speedycgi
2./etc/rc.d/init.d/httpd restart
  
Actual results:
http daemon fails to start.

Expected results:
http starts during boot or a restart

Additional info:
Work around is to 
cd /etc/httpd/conf.d
mv  speedycgi.conf speedycgi.orig
/etc/rc.d/init.d/httpd restart

or

Uninstall the package.
Comment 1 Greg Morgan 2008-05-25 17:02:02 EDT
rpm -q --qf "%{SOURCERPM}\n" -f mod_speedycgi.so 
perl-CGI-SpeedyCGI-2.22-2.fc9.src.rpm
Found the module name based on http://fedoraproject.org/wiki/BugsAndFeatureRequests
Comment 2 Rénald Casagraude 2008-06-26 05:32:11 EDT
The error on this package is the module name…
Replace:
LoadModule speedy_module modules/mod_speedycgi.so
With:
LoadModule speedycgi_module modules/mod_speedycgi.so

And have fun with mod_speedycgi :
http://daemoninc.com/SpeedyCGI/
Comment 3 Joe Orton 2008-10-28 11:45:38 EDT
Looks like I failed to reset the assignee when changing the component :(

Robert, can you fix this?
Comment 4 Robert Scheck 2008-10-28 12:03:42 EDT
Looks good here, reassigning anyway. Greg, I'll have a look into this issue. 
Sorry, that it takes so long, but I was not aware about this bug report. I'll
investigate this evening.
Comment 5 Fedora Update System 2008-10-30 18:47:20 EDT
perl-CGI-SpeedyCGI-2.22-4.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/perl-CGI-SpeedyCGI-2.22-4.fc8
Comment 6 Fedora Update System 2008-10-31 06:23:22 EDT
perl-CGI-SpeedyCGI-2.22-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-10-31 06:24:04 EDT
perl-CGI-SpeedyCGI-2.22-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.