Bug 448342 - squid basic authentication is broken in 3.0 STABLE2
squid basic authentication is broken in 3.0 STABLE2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 23:30 EDT by Mark Orenstein
Modified: 2016-07-26 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 04:44:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Orenstein 2008-05-25 23:30:10 EDT
Description of problem: squid basic authentication is broken in 3.0 STABLE2.  
From the squid mail list

On fre, 2008-05-23 at 14:18 -0400, mrosquid@eastgranby.k12.ct.us wrote:
> I am trying to migrate from squid 2.6 STABLE13-1 on Fedora 6 to squid
> 3.0.STABLE2 on Fedora 9 and can't seem to get basic authentication to
> work.  I even tried the ncsa_auth module without success.  With a ps -A, I
> can see the ncsa_auth child processes.

3.0.STABLE2 is has broken authentication.

Please file a bug report with Fedora, asking for the Squid package to
get updated.  They already have 3.0.STABLE6 integrated, but not pushed
down to Fedora 9...

Regards
Henrik




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Nagy 2008-05-26 04:48:51 EDT
Sure, no problem, I'm planning to update squid in F9 either way.
Comment 2 Fedora Update System 2008-05-26 06:14:20 EDT
squid-3.0.STABLE6-1.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-05-28 22:42:15 EDT
squid-3.0.STABLE6-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update squid'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4500
Comment 4 Tom Hughes 2008-06-03 10:25:09 EDT
I can confirm that upgrading to 3.0.STABLE6-1.fc9 from the testing repository
fixes this problem for me.
Comment 5 Martin Nagy 2008-06-03 11:58:41 EDT
Tom, in that case, please add karma to the update so we can push it.
Comment 6 Tom Hughes 2008-06-03 15:23:38 EDT
Well if I knew how to do that then I'd be glad to... I can't see anything about
karma on the bug anywhere?
Comment 7 Martin Nagy 2008-06-03 15:35:22 EDT
Tom, it's here: https://admin.fedoraproject.org/updates/F9/FEDORA-2008-4500 add
a comment and check the "Works for me" option.
Comment 8 Fedora Update System 2008-06-06 03:51:37 EDT
squid-3.0.STABLE6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.