Bug 448428 - [RHEL4/Evo28] exchange calendars cannot be deleted
[RHEL4/Evo28] exchange calendars cannot be deleted
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution28-evolution-connector (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Matthew Barnes
:
Depends On:
Blocks: 391511
  Show dependency treegraph
 
Reported: 2008-05-26 15:05 EDT by Alan Matsuoka
Modified: 2011-06-29 14:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 20:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evolution28-2.8.0-59.el4-data-server-SEGVd.tgz (9.13 MB, application/x-compressed-tar)
2008-05-26 15:05 EDT, Alan Matsuoka
no flags Details
evolution28-2.8.0-59.el4-exchange-calendar-cannot-delete.tgz (5.95 MB, application/x-compressed-tar)
2008-05-26 15:29 EDT, Alan Matsuoka
no flags Details
sosreport (4.45 MB, application/x-bzip2)
2008-05-26 15:31 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2008-05-26 15:05:41 EDT
Description of problem:

Please find uploaded an archive called:
evolution28-2.8.0-59.el4-exchange-calendar-cannot-delete.tgz

It contains a BT's and a screenshot of the calendars I am trying to delete but
cannot.

I get no message that the task to delete failed or succeded but I remain able to
see the calendars even after a restart of evolution.

I sthere a better way to capture what evolution is doing when I attempt this action?

Are the BT's evident of what transpired?

For the most part this archive uploaded is exactly the same as the one for IT180335.

Regards,
Nick 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:It contains BT's that I could gather and a gcore on
data-server. The data-server SEGV'd as a result of this process:
1. Create a second calendar in my personal account or local acount (NON-exchange)
2. Right mouse click the newly added calendar and select delete.

Then I noticed that gdb prompted on a SEGV with the data-server

I collected the gcore, BT's that I could and a valgrind for this data-server.

I thought about creating a new IT because this is a SEGV on another application
(data-server) but because it was a calendar activity around this case and
happened to behave in a SEGV fashion on the same kind of activity as this IT is
about I decided to place it here in the hopes that it is relavent.


  
Actual results:

Unable to delete calendar

Expected results:

Calendat should be deleted.

Additional info:

Notes from SEG:
I've been able to create and delete calendars without seeing any problems. There
may be something different about the setup used by customer and  the setup we
have here at GSS.
Comment 1 Alan Matsuoka 2008-05-26 15:05:44 EDT
Created attachment 306703 [details]
evolution28-2.8.0-59.el4-data-server-SEGVd.tgz
Comment 2 Alan Matsuoka 2008-05-26 15:29:46 EDT
Created attachment 306705 [details]
evolution28-2.8.0-59.el4-exchange-calendar-cannot-delete.tgz
Comment 3 Alan Matsuoka 2008-05-26 15:31:28 EDT
Created attachment 306706 [details]
sosreport
Comment 4 Matthew Barnes 2008-06-05 16:17:26 EDT
It may be that the calendar Nick's trying to delete no longer exists on the
Exchange server.  Evolution stores the list of Exchange calendars in GConf along
with some local data for each calendar (local cache location, appointment
colors, etc.).  If the calendar is deleted through Evolution on another host, or
through OWA or Outlook or what have you, I'm not sure whether Evolution will
handle that properly.  I still need to find and examine that logic.

For remote calendars that DO still exist on the server, I've been able to delete
them successfully on the GSS server just as Alan mentioned.

There's a workaround for preventing already-deleted calendars from being
displayed in Evolution, but it's a bit painful.  I can provide more details
privately if needed; I don't want to get into a lengthy explanation here.

Neither of the debugging info tarballs appear to have useful data.  The SEGV one
doesn't have a backtrace for the crash and the "cannot-delete" tarball didn't
show anything that looked relevant to the problem.
Comment 5 Matthew Barnes 2008-06-05 16:29:31 EDT
Nick, can you try a few things to get us closer to a reproducible issue?

  1) Try creating a new Exchange calendar in Evolution and then deleting it.
     Does that work?

  2) Try creating a new Exchange calendar though Outlook Web Access.
     Restart Evolution and verify that it sees the new calendar.

  3) Close Evolution and delete the calendar through Outlook Web Access.
     Restart Evolution.  Do you still see the deleted calendar?  If so,
     can you delete it through Evolution?
Comment 10 RHEL Product and Program Management 2008-09-05 13:19:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 RHEL Product and Program Management 2008-09-05 20:45:39 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.