This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 448430 - Yum throwing an AttributeError: CHECKSUM_VALUE on update
Yum throwing an AttributeError: CHECKSUM_VALUE on update
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 15:15 EDT by Vincent Castellano
Modified: 2010-10-22 21:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 09:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vincent Castellano 2008-05-26 15:15:32 EDT
Description of problem:

After an update, I can no longer perform a yum update or yum install.

Version-Release number of selected component (if applicable):

[2008-05-26 12:08 root@box4 sabo]# rpm -qa | grep yum
yum-3.0.1-5.el5
yum-rhn-plugin-0.5.2-5.el5_1.2
yum-metadata-parser-1.0-8.fc6
yum-updatesd-3.0.1-5.el5
yum-metadata-parser-1.1.2-2.el5

Back Trace:

[2008-05-26 12:08 root@box4 sabo]# yum install yum-3.2.8-9.el5_2.1
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-vt-5   100% |=========================| 1.4 kB    00:00
rhn-tools-rhel-x86_64-ser 100% |=========================| 1.2 kB    00:00
Reading repository metadata in from local files
Parsing package install arguments
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 102, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 359, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 134, in doCommand
    return base.installPkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 612, in installPkgs
    self.updatePkgs(userlist=updatelist, quiet=1)
  File "/usr/share/yum-cli/cli.py", line 676, in updatePkgs
    ver=v, rel=r))
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 231, in
searchNevra
    return self._computeAggregateListResult("searchNevra", name, epoch, ver,
rel, arch)
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 323, in
_computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 544, in
searchNevra
    returnList.append(self.pc(rep,self.db2class(x)))
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 429, in db2class
    y.checksum = {'pkgid': 'YES','type': db.checksum_type,
  File "/usr/lib64/python2.4/site-packages/sqlite/main.py", line 97, in __getattr__
    raise AttributeError, key
AttributeError: CHECKSUM_VALUE
Comment 1 James Antill 2008-05-26 17:28:53 EDT
> After an update, I can no longer perform a yum update or yum install.

 What update did you do?

 Does a simple "yum update" get to the "y/N" prompt?
 Does "yum clean all" help?
 Does "yum update yum" work?
Comment 2 James Antill 2008-05-26 17:29:13 EDT
 Also what does:

 yum list yum\*

...display?
Comment 3 Vincent Castellano 2008-05-26 19:38:02 EDT
>  What update did you do?

Whole system, was about 300 packages.

>  Does a simple "yum update" get to the "y/N" prompt?

No, same output at above.

>  Does "yum clean all" help?

Nope

>  Does "yum update yum" work?

Nope, same error.



>  yum list yum\*

[2008-05-26 16:36 root@box3 sabo]# yum list yum\*
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up repositories
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-vt-5   100% |=========================| 1.4 kB    00:00
rhn-tools-rhel-x86_64-ser 100% |=========================| 1.2 kB    00:00
Reading repository metadata in from local files
rhel-x86_6: ################################################## 5337/5337
rhel-x86_6: ################################################## 81/81
rhel-x86_6: ################################################## 103/103
rhel-x86_6: ################################################## 124/124
rhn-tools-: ################################################## 371/371
Installed Packages
yum.noarch                               3.0.1-5.el5            installed
yum-metadata-parser.x86_64               1.1.2-2.el5            installed
yum-metadata-parser.x86_64               1.0-8.fc6              installed
yum-rhn-plugin.noarch                    0.5.2-5.el5_1.2        installed
yum-updatesd.noarch                      3.0.1-5.el5            installed
Available Packages
yum.noarch                               3.2.8-9.el5_2.1        rhel-x86_64-serv
yum-aliases.noarch                       1.1.10-9.el5           rhel-x86_64-serv
yum-basearchonly.noarch                  1.1.10-9.el5           rhel-x86_64-serv
yum-changelog.noarch                     1.1.10-9.el5           rhel-x86_64-serv
yum-downloadonly.noarch                  1.1.10-9.el5           rhel-x86_64-serv
yum-filter-data.noarch                   1.1.10-9.el5           rhel-x86_64-serv
yum-kmod.noarch                          1.1.10-9.el5           rhel-x86_64-serv
yum-list-data.noarch                     1.1.10-9.el5           rhel-x86_64-serv
yum-protect-packages.noarch              1.1.10-9.el5           rhel-x86_64-serv
yum-protectbase.noarch                   1.1.10-9.el5           rhel-x86_64-serv
yum-rhn-plugin.noarch                    0.5.3-6.el5_2.6        rhel-x86_64-serv
yum-security.noarch                      1.1.10-9.el5           rhel-x86_64-serv
yum-skip-broken.noarch                   1.1.10-9.el5           rhel-x86_64-serv
yum-updateonboot.noarch                  1.1.10-9.el5           rhel-x86_64-serv
yum-updatesd.noarch                      1:0.9-2.el5            rhel-x86_64-serv
yum-utils.noarch                         1.1.10-9.el5           rhel-x86_64-serv
yum-versionlock.noarch                   1.1.10-9.el5           rhel-x86_64-serv
Comment 4 James Antill 2008-05-26 19:53:09 EDT
 Can you try removing this:

yum-metadata-parser.x86_64               1.0-8.fc6              installed

...and then doing the "clean all" followed by an update command
Comment 5 James Antill 2008-05-26 19:56:22 EDT
 The command to do that would be:

yum remove yum-metadata-parser-1.0-8.fc6

...or dito. with "rpm -e".
Comment 6 Vincent Castellano 2008-05-26 20:03:20 EDT
Did not change behavior.
Comment 7 Vincent Castellano 2008-05-27 10:48:08 EDT
Also note, that this has happened on several machines I attempted to update at
the same time.
Comment 8 Vincent Castellano 2008-05-27 11:18:54 EDT
Manually updating to yum-3.2.8-9.el5_2.1.noarch fixed it. Seems that an update
got interrupted, and left it in a broken state.
Comment 9 James Antill 2008-05-27 11:22:57 EDT
 Do they all have the new and old versions of yum-metadata-parser?
Comment 10 Vincent Castellano 2008-05-27 11:28:28 EDT
Yes, they do.
Comment 14 Sam Folk-Williams 2008-06-18 12:22:45 EDT
(In reply to comment #7)
> Also note, that this has happened on several machines I attempted to update at
> the same time.

Did the initial update complete without error (When you updated the whole system)?

If that initial updated failed, did you notice if these multiple machines had
the yum update fail on the same package? Any idea what yum was doing (what
package was being updated/installed) at the time of the failure?
Comment 15 Denise Dumas 2008-07-11 11:52:25 EDT
Setting 5.3 to "?" so this shows up on queries ..
Comment 16 RHEL Product and Program Management 2008-07-11 12:00:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 22 Rich Johnson 2008-08-16 14:50:29 EDT
(In reply to comment #8)
> Manually updating to yum-3.2.8-9.el5_2.1.noarch fixed it. Seems that an update
> got interrupted, and left it in a broken state.

What's the command incantation for recovery via manual update?....rpm?....yum?

I'm now stuck in this state after a yum update of several hundred packages was interrupted.
Comment 23 James Antill 2008-09-30 10:12:01 EDT
 You can run "yum-complete-transaction" ... but alas. that assumes yum itself is still functional.

 Assuming yum isn't functional you want to do something like:

rpm -qa | egrep 'yum|rpm'

...then, if it's like the cases I've seen, you'll have two yum-metadata-parser packages installed. You need to remove one of them (remove the newer one if you still have yum-3.0.1 and the older one otherwise -- using rpm -e).
 At which point yum/yum-complete-transaction should work again.
Comment 24 Denise Dumas 2008-10-07 09:57:36 EDT
This problem occurred because yum-metadata-parser was half-upgraded. We do not plan to update this again in the rhel5 stream, which means that the likelihood of this problem recurring is vanishingly low. So I'm closing this, with the caveat that if plans change and we have to update yum-metadata-parser, we'll be sure this case can't happen.

Note You need to log in before you can comment on or make changes to this bug.