Bug 448474 - suid: considered unprelinking?
suid: considered unprelinking?
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sectool (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 03:18 EDT by Miloslav Trmač
Modified: 2008-05-27 11:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 11:52:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2008-05-27 03:18:15 EDT
Description of problem:
The suid test warns:
 This test is not useful if you use prelinking as prelink modifies binaries,
changing their md5 sums

Have you considered using (prelink --md5)?  The test would probably become much
slower, but perhaps it is worth it.

Version-Release number of selected component (if applicable):
sectool-0.7.4-1.i386
Comment 1 Jakub Hrozek 2008-05-27 11:52:11 EDT
We use rpm for checking md5 sums now (in whole sectool, not just the suid 
test). I've removed the warning since it makes no sense.

Note You need to log in before you can comment on or make changes to this bug.