Bug 448506 - PI fails everytime with Java testcase with the new -57 kernel
PI fails everytime with Java testcase with the new -57 kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
beta
x86_64 All
low Severity urgent
: ---
: ---
Assigned To: Red Hat Real Time Maintenance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 06:40 EDT by IBM Bug Proxy
Modified: 2008-06-09 11:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.24.7-65.el5rt
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 11:12:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 45090 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-05-27 06:40:24 EDT
=Comment: #0=================================================
Dinakar Guniguntala <Dinakar.G@in.ibm.com> - 2008-05-26 10:42 EDT
Problem description:
  PI fails everytime with Java testcase with the new -57 kernel

  -------------------------------
  Priority Inheritance
  -------------------------------

  Perform concurrent calculations using normal priority threads
  with two low/high priority threads both sharing a common lock.
  High priority lock acquisition maximum delay: 21.26 ms
  Low priority lock held time: 5.970 ms
  Checks maximum delay < low thread lock held time + 200 µs : FAIL

  With earlier kernels it was something like this below

  -------------------------------
  Priority Inheritance
  -------------------------------

  Perform concurrent calculations using normal priority threads
  with two low/high priority threads both sharing a common lock.
  High priority lock acquisition maximum delay: 5.496 ms
  Low priority lock held time: 5.980 ms
  Checks maximum delay < low thread lock held time + 200 µs : PASS

Provide output from "uname -a", if possible:

  Linux rt-ipe.austin.ibm.com 2.6.24.7-57ibmrt2.3 #1 SMP PREEMPT RT Wed May 21
19:51:04 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux


Hardware Environment
  HS21

Additional Information:

 2.6.24.7-57ibmrt2.3 is exactly the same as the RH 2.6.24.7-57 kernel.

 To avoid a application hang documented in bug 44781 (RH446397)
 the following was set before running the application

 echo 1 >/proc/sys/kernel/rwlock_reader_limit
Comment 1 IBM Bug Proxy 2008-05-27 19:24:27 EDT
------- Comment From jstultz@us.ibm.com 2008-05-27 19:19 EDT-------
If I re-enabled the multi-reader code w/:
echo 0 > /proc/sys/kernel/rwlock_reader_limit

the PI regressions go away.

So this looks like its connected w/ the rwlock changes.
Comment 2 IBM Bug Proxy 2008-05-29 21:17:54 EDT
------- Comment From jstultz@us.ibm.com 2008-05-29 21:17 EDT-------
With the fix for LTC bug #44781 now being tested, it is likely this issue can be
closed as well. I'll confirm the issue goes away as soon as our internal build,
including the fix from LTC bug #44781, is finished.
Comment 3 IBM Bug Proxy 2008-05-30 15:57:41 EDT
------- Comment From jstultz@us.ibm.com 2008-05-30 15:51 EDT-------
Verified with Steven's fix this issue goes away.

------- Comment From jstultz@us.ibm.com 2008-05-30 15:52 EDT-------
Need to verify -62 is all well and good and we'll move this to accepted.
Comment 4 IBM Bug Proxy 2008-06-02 09:48:31 EDT
------- Comment From sripathi@in.ibm.com 2008-06-02 09:43 EDT-------
Tested this with -62 kernel. PI test did not fail even once in 20 runs. So this
seems to be fixed as well. Closing the bug on our side.
Comment 5 Clark Williams 2008-06-09 11:12:31 EDT
closing here as well

Note You need to log in before you can comment on or make changes to this bug.