Bug 448533 - conflict between domains in libvirt hash
conflict between domains in libvirt hash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks: 449772
  Show dependency treegraph
 
Reported: 2008-05-27 10:05 EDT by Daniel Veillard
Modified: 2010-10-22 21:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Veillard 2008-05-27 10:05:41 EDT
Description of problem:
When removing domains, within some circumstances, one can get
libvirt corruption or even segfault


Version-Release number of selected component (if applicable):


How reproducible:
systematic

Steps to Reproduce:
   1. create the following configuration file to '/etc/xen/'                    
      - test01                                                                  
      - test22                                                                  
   2. start the virt-manager, and check the domain list                         
      # virt-manager --no-fork                                                  
   3. undefine 'test01'                                                         
      # virsh undefine test01                                                   
   4. wait until updating the 'test01' status of virt-manager                   
      # virt-manager --no-fork                                                  
      Segmentation fault                                                        
   --- if any problem is not occurred, please repeat 5,6,7 ---                  
   5. create the following configuration file to '/etc/xen/'                    
      - test01                                                                  
   6. undefine 'test01'                                                         
      # virsh undefine test01                                                   
   7. wait until updating the 'test01' status of virt-manager
  
Actual results:
virt-manager crashes

Expected results:
no crash and virt-manager properly updates the list


Additional info:

It's actually caused by a bug in libvirt hash table code 
when two domain shares the same line of the hash
The bug was explained upstream by Hiroyuki Kaguchi,
and applied upstream back in February 2008

http://git.et.redhat.com/?p=libvirt.git;a=commitdiff;h=649081e7c17cc97a68ccd6eebc31699d6256586a;hp=5ebab1b01da1d45c74864e0b55c8b715e9286bc2
Comment 3 RHEL Product and Program Management 2008-06-02 15:56:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Alexander Todorov 2008-06-09 07:20:48 EDT
Is bug #450511 a duplicate of this one? 

Thanks!
Comment 5 Daniel Veillard 2008-06-18 11:54:11 EDT
libvirt-0.3.3-8.el5 has been built in dist-5E-qu-candidate with the fix,

Daniel
Comment 9 errata-xmlrpc 2009-01-20 16:21:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0142.html

Note You need to log in before you can comment on or make changes to this bug.