Bug 448619 - Duplicate Labels from Software RAID cause installer to fail
Duplicate Labels from Software RAID cause installer to fail
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 17:15 EDT by Jeff Turkstra
Modified: 2008-05-28 18:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 18:02:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Turkstra 2008-05-27 17:15:14 EDT
Description of problem:
I'm attempting to upgrade from Fedora 8->9 and am running into a problem. The
installer complains about multiple devices on the system having duplicate
labels. I can see this when I run blkid....
/dev/sdb1: UUID="f64f73ae-a7b8-c3f3-c99b-51f87ca65c04" TYPE="mdraid"
/dev/sdc1: UUID="f64f73ae-a7b8-c3f3-c99b-51f87ca65c04" TYPE="mdraid"
/dev/sdd1: UUID="f64f73ae-a7b8-c3f3-c99b-51f87ca65c04" TYPE="mdraid"
/dev/sde1: UUID="f64f73ae-a7b8-c3f3-c99b-51f87ca65c04" TYPE="mdraid" 

However, since all four of the above partitions are members of md0, a RAID-5
Linux software RAID device, I can't change the UUID or set a label using the
usual tune2fs/e2label programs. In fact, it seems as though they're supposed to
have the same UUID - I'm not sure on that though, running mdadm -E on each
yields a different (but still common across all 4) UUID.

Regardless, this causes the installer to fail miserably. Any workaround would be
appreciated - either a way to change the UUID on a block device lacking a
filesystem (part of a software raid array) or to get the installer to ignore the
fact that the UUID's are identical.
Comment 1 Jeff Turkstra 2008-05-28 18:02:49 EDT
I discovered the problem. The partition type must be set to "Linux raid auto"
for anaconda to allow duplicate UUID's. This is different from earlier versions
of Fedora, but I think the problem can be considered to be on my end. Sorry for
the trouble!

Note You need to log in before you can comment on or make changes to this bug.