Bug 448620 - traceback: AttributeError: 'NoneType' object has no attribute 'dbMatch'
traceback: AttributeError: 'NoneType' object has no attribute 'dbMatch'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 17:39 EDT by Zing
Modified: 2014-01-21 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version: 3.2.16-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 20:30:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zing 2008-05-27 17:39:41 EDT
Description of problem:
In yum shell, say No to the download packages when updating, and then run
transaction again... get traceback from yum.

Version-Release number of selected component (if applicable):
yum-3.2.14-10.fc9.noarch

How reproducible:
always

Steps to Reproduce:
# yum shell
Loaded plugins: changelog, downloadonly
Setting up Yum Shell
> update
Setting up Update Process
> ts list

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 exempi                  x86_64     2.0.1-1.fc9      updates           290 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

> run
--> Running transaction check
---> Package exempi.x86_64 0:2.0.1-1.fc9 set to be updated
--> Finished Dependency Resolution

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 exempi                  x86_64     2.0.1-1.fc9      updates           290 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 290 k
Is this ok [y/N]: 
Exiting on user Command
Transaction did not run.
> run    
--> Running transaction check
--> Finished Dependency Resolution
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 116, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 311, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 592, in doCommand
    return base.doShell()
  File "/usr/share/yum-cli/cli.py", line 254, in doShell
    yumshell.cmdloop()
  File "/usr/lib64/python2.5/cmd.py", line 142, in cmdloop
    stop = self.onecmd(line)
  File "/usr/lib64/python2.5/cmd.py", line 219, in onecmd
    return func(arg)
  File "/usr/share/yum-cli/shell.py", line 322, in do_run
    (code, msgs) = self.base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 628, in
buildTransaction
    self._limit_installonly_pkgs()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 2703, in
_limit_installonly_pkgs
    (cur_kernel_v, cur_kernel_r) = misc.get_running_kernel_version_release(self.ts)
  File "/usr/lib/python2.5/site-packages/yum/misc.py", line 465, in
get_running_kernel_version_release
    mi = ts.dbMatch('basenames', fn)
  File "/usr/lib/python2.5/site-packages/rpmUtils/transaction.py", line 59, in
__getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.5/site-packages/rpmUtils/transaction.py", line 69, in
getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'dbMatch'
  
Expected results:
no traceback.  rerun the transaction.
Comment 1 Seth Vidal 2008-05-30 12:47:56 EDT
Can you get this to happen on 3.2.16, too?
Comment 2 Zing 2008-05-30 20:30:29 EDT
looks good... works for me.

Note You need to log in before you can comment on or make changes to this bug.