Bug 448631 - Flash does not work in 64 bit Firefox 3.
Flash does not work in 64 bit Firefox 3.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 19:10 EDT by wdc
Modified: 2008-06-05 08:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 08:33:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wdc 2008-05-27 19:10:20 EDT
Description of problem:

When I was beta testing RHEL 5.2, I discovered Flash didn't work.
Somehow I very quickly found a bug report somewhere that explained
that the problem was that the nspluginwrapper wasn't being installed
for 64 bits, and so I figured the problem was under control.

Using RHEL 5.2 now that it has shipped, I discover that flash works
fine in 32 bit RHEL, but is NOT detected on the 64 bit platform.
Worse, I cannot find the bug report that simply and clearly stated
the problem and the solution.

Perhaps I've made the wrong diagnosis.  But at any rate, I've tested 
under 32 bits, and Flash loads right up and works perfectly.  But under 64 bit
it does not.



Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Visit a flash site in 64 bit RHEL 5.2 Firefox 3.0 beta 5.
2. Follow the prompts to install the flash plugin RPM
3. about:plugins shows no Flash detected after restarting firefox.
  
Actual results:

No flash detected


Expected results:

The flash plugin should have been detected and run.


Additional info:
Comment 1 Martin Stransky 2008-05-28 02:39:22 EDT
Do you have the nspluginwrapper package installed? (You need both i386 and x86_64).
Comment 2 Matěj Cepl 2008-05-28 04:35:13 EDT
It's much better to install flash from Adobe repo (install
http://linuxdownload.adobe.com/adobe-release/adobe-release-i386-1.0-1.noarch.rpm) and
then with both nspluginwrapper.i386, and nspluginwrapper.x86_64 everything works
well.
Comment 3 wdc 2008-05-28 10:04:36 EDT
Ah HA!
As soon as I explilcitly did a "yum install nspluginwrapper" it worked.

The source of the flash plugin was Adobe.  Can we keep this bug open for a little longer so that we can 
document why where I went on adobe did not install nspluginwrapper?
Comment 4 Matěj Cepl 2008-05-28 15:40:21 EDT
Sure, let's just mark that we are expecting a stuff from you.
Comment 5 wdc 2008-06-03 20:20:33 EDT
Sorry for the delay in following up.  Had a couple other urgent tasks jump out at me.

The link we follow to obtain the flash plug in is:
http://www.macromedia.com/go/getflashplayer
That redirects to:
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash

Selecting the "rpm for Linux" product, the "Agree and install now" button goes to:
http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-9.0.124.0-
release.i386.rpm

At first I thought that the problem was that the flash plugin was i386, and that Adobe was not 
giving me a 64 bit flash package which would have contained a 64 bit nspluginwrapper to make the 32 
bit flash work.  But listing the contents of that RPM shows no nspluginwrapper in the RPM.
Something ELSE seems to be getting nspluginwrapper right for RHEL 5.1 32 bit, RHEL 5.1 64 bit, and 
RHEL 5.2 32 bit but NOT for RHEL 5.2 64 bit.

Listing the contents of the RPM you suggest above, I see that that's only a yum repo spec into Adobe.
So it seems like that too expects something else to take responsibility for having installed 
nspluginwrapper.  I believe I would still have to explicitly perform "yum install nspluginwrapper".

What I'm getting to here is:

Why does an install of flash on the three platforms, 32 bit RHEL 5.1, 64 bit RHEL 5.1 with Firefox 1.5 
and 32 bitRHEL 5.2  with Firefox 3 just work, but the same flash
install under 64 bit RHEL 5.2 require me to explicitly install nspluginwrapper?

I mean MIT *CAN* produce end-user "known issues with RHEL 5.2 64 bit" help page that says, "Unlike 
everything else you do under RHEL 5, RHEL 5.2 64 is special and requires this extra step."

Does the RHEL 5 Firefox install nspluginwrapper by default, and is it possible that the 64 bit 
nspluginwrapper was supposed to be installed by default either by the Firefox RPM or by something 
else, but this time around was not?


Comment 6 Martin Stransky 2008-06-04 01:38:46 EDT
Ehm, would you like to say that flash works out-of-the box on RHEL 5.1 and 64
bit browser? That must be a miracle. 

Flash is a 32-bit plugin and it can't work with 64-bit browsers. Nspluginwrapper
is a new package (in rhel-5.2) which is supposed to run the 32-bit plugins in
64-bit environment (64-bit browser). 

Maybe you just used to tun 32-bit browser in 64-bit environment. In that case
flash really works out-of-the box.
Comment 7 wdc 2008-06-04 10:06:30 EDT
I will check the RHEL 5.1 system and see if 32 bit Firefox 1.5 is what got installed.
Indeed that is a quite sensible and reasonable explanation for the behavior I have seen.  Thank you.
I'll check on that and get back to you.

It does seem more likely that Red Hat bundled in 32 bit Firefox 1.5 rather than that a special default was
crafted to make sure 64 bit nspluginwrapper was installed by default with Firefox 1.5.
Comment 8 wdc 2008-06-04 17:37:00 EDT
I just re-ran my test on a clean RHEL 5.1 install, and discovered it was MY MISTAKE.
I don't know how I got it into my head that flash worked on 64 bit RHEL 5.1, but in fact the
behavior is the same as under RHEL 5.2, and indeed we just need to tell people to

yum install nspluginwrapper

Thank you for humoring me as I explored this issue.
I apologize for wasting your time with my careless testing.
You should close this issue with status NOTABUG.
Comment 9 Matěj Cepl 2008-06-05 08:33:36 EDT
Gladly do. Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.