This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448679 - Text-mode results output format
Text-mode results output format
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sectool (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 03:58 EDT by Miloslav Trmač
Modified: 2008-07-10 08:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 08:26:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2008-05-28 03:58:19 EDT
Description of problem:
The test header format, with "Test name: ..." on the left and "Test result: " on
the right does not quite feel right to me:
- A spartan "suid: OK" would convey the same information in two words - although
  that's perhaps too terse.
- Although matching the left and right side of the row with eyes is not too
  difficult, it does feel somewhat inconvenient
- At minimum, please fix the text width computation used for right-aligning the
  test result string to correctly handle non-ASCII characters (ideally using
  wcwidth() or an equivalent)

Version-Release number of selected component (if applicable):
sectool-0.7.4-1.i386
Comment 1 Jakub Hrozek 2008-06-02 07:54:14 EDT
Yes, the text interface needs an overhaul, I'm working on it now. Thank you 
for reporting the bug as well as for the suggestions.
Comment 2 Jakub Hrozek 2008-06-20 10:06:39 EDT
OK, this is fixed in HEAD, the current format looks like:

---
Running test: foobar
    Error(01)      All your system are belong to us
    Warning(02)    Some more text
foobar: ERRROR
---

Also, the messages are now printed on-the-fly, not after the whole test 
finishes which makes it somewhat more convenient for tests that take a long 
time.
Comment 3 Jakub Hrozek 2008-07-10 08:26:50 EDT
Fixed in sectool 0.8 which is now present in rawhide. Closing.

Note You need to log in before you can comment on or make changes to this bug.