Bug 448716 - help doesn't show when running VM in privileged mode and without --no-fork
help doesn't show when running VM in privileged mode and without --no-fork
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 08:36 EDT by Alexander Todorov
Modified: 2009-12-14 16:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:42:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-05-28 08:36:12 EDT
Description of problem:
The help doesn't show sometimes. See below for more information

Version-Release number of selected component (if applicable):
virt-manager-0.5.3-8.el5

How reproducible:
Always in selected cases

Steps to Reproduce:
1. run virt-manager from the terminal as non root
2. enter the root password
3. select Help -> Contents or Edit -> Preferences -> Help
  
Actual results:
no help shows

Expected results:
help window shows

Additional info:
Works when:
* start VM from the GNOME applet in unprivileged mode; or
* run virt-manager from the terminal in unprivileged mode; or
* run virt-manager --no-fork in unprivileged mode; or
* run virt-manager --no-fork and enter the root password

Doesn't work when:
* start VM from the GNOME applet and enter the root password; or
* run virt-manager from the terminal and enter the root password

In the common use case where VM is started as non root user who enters the root
password in order to perform some tasks the help is not available (i.e. clicking
on the above buttons/menus does nothing).

In the cases described as "works" clicking the menus opens the Virtual Machine
Manager Manual.
Comment 1 RHEL Product and Program Management 2008-06-02 15:56:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Cole Robinson 2009-06-08 11:28:52 EDT
All access to the help documentation has been dropped, since it is out of date
and near useless (see 443628 and 460713). As a side effect, this bug is
effectively fixed. The root issue is that forking off the app, and then using
console kit to gain root privs causes errors when trying to launch the help
viewer. 

Fix built into virt-manager 0.6.1-3.el5. Setting to MODIFIED.
Comment 8 errata-xmlrpc 2009-09-02 05:42:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1285.html

Note You need to log in before you can comment on or make changes to this bug.