Bug 448731 - impose restrictions on partition tables of type msdos
impose restrictions on partition tables of type msdos
Status: CLOSED DUPLICATE of bug 447768
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: parted (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Joel Andres Granados
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 10:34 EDT by Adam Stokes
Modified: 2008-06-10 10:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 10:12:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stokes 2008-05-28 10:34:54 EDT
Description of problem:
I'm not exactly sure where the defining line is but somewhere around the size of
1-2TB MSDOS partitions are no longer able to handle the full size of the disks.
This causes all sorts of unexpected problems:

# juno578 /root > parted /dev/sdb print

Model: AMCC 9650SE-8LP DISK (scsi)
Disk /dev/sdb: 6000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End  Size  Type  File system  Flags

Information: Don't forget to update /etc/fstab, if necessary.            

                                          


Version-Release number of selected component (if applicable):
1.8.1

How reproducible:
100%

Steps to Reproduce:
1.# juno578 /root > parted -i /dev/sdb
GNU Parted 1.8.1
Using /dev/sdb
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) mkpart                                                           
Partition type?  primary/extended? primary                                
File system type?  [ext2]? ext3                                          
Start? 0                                                                  
End? -1                        
2. 
3.
  
Actual results:
(parted) print                                                            

Model: AMCC 9650SE-8LP DISK (scsi)
Disk /dev/sdb: 6000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
1      0.51kB  1602GB  1602GB  primary                    

(parted)                                                                  

# juno578 /root > fdisk /dev/sdb

The number of cylinders for this disk is set to 729447.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
  (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/sdb: 5999.9 GB, 5999909928960 bytes
255 heads, 63 sectors/track, 729447 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1      194749  1564319743+  83  Linux

Command (m for help): d
Selected partition 1

Expected results:
Warn of type msdos and setup constraints suitable for that type

Additional info:
Something like below should be implemented
http://article.gmane.org/gmane.comp.gnu.parted.bugs/9371
Comment 1 RHEL Product and Program Management 2008-06-02 15:56:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Joel Andres Granados 2008-06-10 10:12:10 EDT

*** This bug has been marked as a duplicate of 447768 ***

Note You need to log in before you can comment on or make changes to this bug.