Bug 448746 - coda should init rvm db at first run
coda should init rvm db at first run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 11:40 EDT by Adam Goode
Modified: 2008-05-28 14:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 14:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Goode 2008-05-28 11:40:10 EDT
Description of problem:
The first time coda is run, it should create the rvm database. Otherwise, it fails.

Here is a suggested addition to the initscript:
[ -f /var/lib/coda/LOG ] || touch /var/cache/coda/INIT


Version-Release number of selected component (if applicable):
coda-client-6.9.3-2.fc9.x86_64
Comment 1 Adam Goode 2008-05-28 11:41:40 EDT
Oops, you should obviously use the correct paths.
Comment 2 Hans de Goede 2008-05-28 13:56:08 EDT
I could add this, but I don't see the use of this, the initscript will not start
venus unless /etc/coda/venus.conf is present. To create this file the user
should run venus-setup which will also init the rvm for the user.
Comment 3 Adam Goode 2008-05-28 14:03:44 EDT
Ok, that seems reasonable.

Note You need to log in before you can comment on or make changes to this bug.