Bug 448822 - New fence_ilo script doesn't work on iLO 2 1.43
New fence_ilo script doesn't work on iLO 2 1.43
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Marek Grac
Cluster QE
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 17:15 EDT by Ryan McCabe
Modified: 2016-04-26 21:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan McCabe 2008-05-28 17:15:24 EDT
The power on and power off CLI commands do nothing on iLO 2 (at least with this
firmware revision). The old script works correctly.

When I try to power off or reboot the machine, I get this output until the power
off timeout is reached:

iLO Advanced 1.43 at 14:00:07 Dec 12 2007
Server Name: host is unnamed
Server Power: On

</>hpiLO-> POWER

power: server power is currently: On

</>hpiLO-> power off


</>hpiLO-> POWER

power: server power is currently: On

</>hpiLO-> POWER

power: server power is currently: On


iLO details:
Server Name: 	host is unnamed; ProLiant BL45p G2
License Type: 	iLO 2 Standard Blade Edition
iLO 2 Firmware Version: 	1.43   12/12/2007
Comment 1 Ryan McCabe 2008-05-28 17:39:46 EDT
This looks like a problem with the iLO 2 CLI.

The log file records the attempts to power off the machine:

Caution iLO 2 05/28/2008 21:37 05/28/2008 21:37 11 Power-Off signal sent to host
server by: root.

But nothing happens. I've been digging around the CLI, but I can't find a way to
make it power off the machine.
Comment 2 Marek Grac 2008-06-05 13:57:24 EDT
After few tests from CLI:
 * reboot works
 * command 'power on' works (after power off from web)
 * power off => problem
Comment 3 Marek Grac 2008-07-02 11:04:37 EDT
These agents are not in RHEL4/RHEL5 branhes now. Fix is available in master
branch (contain also telnet with ssl support). Adds dependepency on pyOpenSLL
Comment 4 Marek Grac 2008-08-27 08:29:03 EDT
Added to RHEL5 branch
Comment 5 Marek Grac 2008-08-27 08:29:25 EDT
oops, RHEL4
Comment 9 Chris Feist 2009-04-27 16:08:07 EDT
Fix is in fence-1.32.64 and beyond.  Adding to errata.
Comment 12 errata-xmlrpc 2009-05-18 17:15:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1050.html

Note You need to log in before you can comment on or make changes to this bug.