This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448842 - SELinux interfering with sosreport
SELinux interfering with sosreport
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.6
i386 Linux
low Severity low
: rc
: ---
Assigned To: Keith Robertson
BaseOS QE - Apps
: FutureFeature
Depends On:
Blocks: 502912 554476 590060
  Show dependency treegraph
 
Reported: 2008-05-28 20:23 EDT by Nik Lam
Modified: 2016-07-03 21:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-05 14:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Text dump of the selinux alert notification (3.21 KB, text/plain)
2008-05-28 20:23 EDT, Nik Lam
no flags Details
Text dump of the selinux alert notification (3.21 KB, text/plain)
2008-06-03 19:55 EDT, Nik Lam
no flags Details
Text dump of the selinux alert notification (3.21 KB, text/plain)
2008-06-03 19:56 EDT, Nik Lam
no flags Details
Text dump of the selinux alert notification (3.12 KB, text/plain)
2008-06-03 19:56 EDT, Nik Lam
no flags Details

  None (edit)
Description Nik Lam 2008-05-28 20:23:55 EDT
Description of problem:

SELinux is preventing ld-linux.so.2 from loading
/usr/lib/libSDL-1.2.so.0.7.3.#prelink#.Cjl0lV which requires text relocation. 


Version-Release number of selected component (if applicable):
RHEL 5.2 i386 Desktop

How reproducible:

I've run sosreport twice and it's done it both times.


Steps to Reproduce:
1. Log into gnome desktop
2. Open gnome terminal
3. run "sudo /usr/sbin/sosreport"
  
Actual results:
During the sosreport generation, SELinux alert pops up an alert (see
attachment). sos report does complete.

Expected results:

sos completes without SELinux alert warning.

Additional info:
Comment 1 Nik Lam 2008-05-28 20:23:55 EDT
Created attachment 307001 [details]
Text dump of the selinux alert notification
Comment 2 Adam Stokes 2008-06-03 07:04:36 EDT
After running :

chcon -t textrel_shlib_t '/usr/lib/libSDL-1.2.so.0.7.3.#prelink#.Cjl0lV'

Does sosreport complete? And are you willing to provide me with the sosreport?

Thanks
Adam
Comment 3 RHEL Product and Program Management 2008-06-03 07:16:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Nik Lam 2008-06-03 19:54:43 EDT
Actually, having tried the context change as requested, I've realised that the
offending file actually changes each time, so the context change recommended by
SELinux alert after one sosreport has no bearing on the next sosreport and as
similar alert pops up, just complaining about a different file.

I've opened service request #1832408 where I'll put my sosreports.

I'll attache a couple more SELinux Alert notifications.
Comment 5 Nik Lam 2008-06-03 19:55:18 EDT
Created attachment 308305 [details]
Text dump of the selinux alert notification
Comment 6 Nik Lam 2008-06-03 19:56:03 EDT
Created attachment 308306 [details]
Text dump of the selinux alert notification
Comment 7 Nik Lam 2008-06-03 19:56:31 EDT
Created attachment 308307 [details]
Text dump of the selinux alert notification
Comment 8 RHEL Product and Program Management 2008-10-27 14:22:45 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 14 RHEL Product and Program Management 2010-08-10 04:42:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Unfortunately, Red Hat is unable to address this request in the
current release.  Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 16 Bryn M. Reeves 2011-04-06 09:55:07 EDT
I'm not able to reproduce this but it seems odd that there are prelink temporary files left lying around like this:

/usr/lib/libSDL-1.2.so.0.7.3.#prelink#.Cjl0lV

That .#prelink#.<random> indicates that this is a prelink temp file. They should not be lying around the file system.

Was prelink running while sos ran?
Comment 17 Nik Lam 2011-04-24 06:23:40 EDT
Hi. Sorry but I no longer work at the site where this host is, so don't have access to it.

From what I understand of prelink though (not a whole lot), I think it would be pretty unlikely for it to have been running every time I tried to run the sos report - if I recall correctly, I tried several attempts over the course of several days.

It's likely that this host has been decommissioned, so if there have been no other users reporting similar issues, maybe it was just a once-off problem with prelink???
Comment 18 RHEL Product and Program Management 2011-06-05 14:54:44 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.