Bug 448848 - livecd-creator is not working - trying to build minimal LiveCD
livecd-creator is not working - trying to build minimal LiveCD
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 21:34 EDT by Luis Felipe Marzagao
Modified: 2014-01-21 01:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 14:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Felipe Marzagao 2008-05-28 21:34:22 EDT
Description of problem:

livecd-creator is not working.

Version-Release number of selected component (if applicable):

[root@localhost livecd-tools]# rpm -q livecd-tools
livecd-tools-017-1.fc9.x86_64


How reproducible:

always

Steps to Reproduce:

[root@localhost livecd-tools]# livecd-creator -c livecd-fedora-minimal.ks -f
Minimal 

mke2fs 1.40.8 (13-Mar-2008)
Warning: 256-byte inodes not usable on older systems
Filesystem label=Minimal
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
65536 inodes, 262144 blocks
2621 blocks (1.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=268435456
8 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376

Writing inode tables: done                            
Creating journal (8192 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 29 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
tune2fs 1.40.8 (13-Mar-2008)
Setting maximal mount count to -1
Setting interval between checks to 0 seconds
Retrieving file:///mnt/st/repos/f9/everything/repodata/repomd.xml ...OK
Retrieving file:///mnt/st/repos/f9/everything/repodata/primary.xml.gz ...OK
Retrieving file:///mnt/st/repos/f9/updates/repodata/repomd.xml ...OK
Retrieving file:///mnt/st/repos/f9/updates/repodata/primary.xml.gz ...OK
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 132, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 124, in main
    print >> sys.stderr, "Error creating Live CD : %s" % e
UnicodeEncodeError: 'ascii' codec can't encode character u'\xed' in position 58:
ordinal not in range(128)

  
Actual results:

The program stops with erros.


Expected results:

The livecd should be created.
Comment 1 Jeremy Katz 2008-05-28 21:43:17 EDT
What locale and what version of yum?
Comment 2 Luis Felipe Marzagao 2008-05-28 22:17:38 EDT
Hello:

[root@localhost livecd-tools]# set | grep -i lang
LANG=pt_BR.UTF-8

[root@localhost livecd-tools]# rpm -q yum
yum-3.2.14-10.fc9.noarch
Comment 3 Jeremy Katz 2008-05-28 22:56:44 EDT
Can you try with yum-3.2.16 which should be in -updates-testing?
Comment 4 Luis Felipe Marzagao 2008-05-29 22:11:32 EDT
I think it's already in fedora-updates, since I have it here:

[root@localhost livecd-tools]# rpm -q yum
yum-3.2.16-2.fc9.noarch

The same error is occuring.

thanks
Comment 5 Jeremy Katz 2008-06-01 20:55:10 EDT
I just tried with your lang settings and 3.2.16 and can't get this to occur
(although I do hit it with 3.2.14)

Can you try grabbing http://katzj.fedorapeople.org/livecd-creator and running
using it as it should give some more debugging information.
Comment 6 Luis Felipe Marzagao 2008-06-02 19:32:44 EDT
This is what I got running the suggested livecd-creator:

(PS: I just did a fresh install... This is system is really clean)

[root@localhost livecd-tools]# livecd-creator-katz -c livecd-fedora-minimal.ks
-f minimal.iso && echo ok
mke2fs 1.40.8 (13-Mar-2008)
Warning: 256-byte inodes not usable on older systems
Filesystem label=minimal.iso
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
65536 inodes, 262144 blocks
2621 blocks (1.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=268435456
8 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376

Writing inode tables: done                            
Creating journal (8192 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 35 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
tune2fs 1.40.8 (13-Mar-2008)
Setting maximal mount count to -1
Setting interval between checks to 0 seconds
Retrieving file:///mnt/st/repos/f9/everything/repodata/repomd.xml ...OK
Retrieving file:///mnt/st/repos/f9/everything/repodata/primary.xml.gz ...OK
Retrieving file:///mnt/st/repos/f9/livna/repodata/repomd.xml ...OK
Retrieving file:///mnt/st/repos/f9/livna/repodata/primary.xml.gz ...OK
Retrieving file:///mnt/st/repos/f9/updates/repodata/repomd.xml ...OK
Retrieving file:///mnt/st/repos/f9/updates/repodata/primary.xml.gz ...OK
Traceback (most recent call last):
  File "/usr/bin/livecd-creator-katz", line 132, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator-katz", line 115, in main
    creator.install()
  File "/usr/lib/python2.5/site-packages/imgcreate/creator.py", line 579, in install
    self.__select_packages(ayum)
  File "/usr/lib/python2.5/site-packages/imgcreate/creator.py", line 522, in
__select_packages
    (pkg, e))
imgcreate.errors.CreatorError

[root@localhost livecd-tools]# 


Thanks
Comment 7 Jeremy Katz 2008-06-02 19:39:43 EDT
That line is an error because your config is specifying a missing package.  And
I notice that your config is pulling in repos which aren't in the stock minimal
config.  Cna you attach your config?
Comment 8 Jeremy Katz 2008-06-02 20:46:32 EDT
Actually, reproduced and I see what's going on.  Removing the package that
doesn't exist from your config will work.

Really fixing has to be done in yum as the exception has unicode text which is
not the norm
Comment 9 Luis Felipe Marzagao 2008-06-02 23:07:58 EDT
Hello: Here is my config file. Hope it helps. What package should be removed?

lang en_US.UTF-8
keyboard us
timezone US/Eastern
auth --useshadow --enablemd5
selinux --enforcing
firewall --disabled
part / --size 1024

repo --name=lf	--baseurl=file:///mnt/st/repos/f9/everything/
repo --name=lu	--baseurl=file:///mnt/st/repos/f9/updates/
repo --name=ll	--baseurl=file:///mnt/st/repos/f9/livna/
#repo --name=du	--baseurl=file:///mnt/st/repos/duli/

#repo --name=development
--mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?#repo=rawhide&arch=$basearch


%packages
@core
bash
kernel
passwd
policycoreutils
chkconfig
authconfig
rootfiles

%end
Comment 10 seth vidal 2008-09-03 09:42:54 EDT
Jeremy,
 What's the best way to replicate this error to see if it has been fixed in 3.2.19?
Comment 11 Junior 2008-10-17 21:50:28 EDT
I have the same error to generate my livecds.

Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 132, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 124, in main
    print >> sys.stderr, "Error creating Live CD : %s" % e
UnicodeEncodeError: 'ascii' codec can't encode character u'\xed' in position 56: ordinal not in range(128)


The strange if this error, only occurs to generate livecds of Fedora 9 KDE and to generate livecds of Fedora 10 occurs normally.
Comment 12 seth vidal 2008-11-07 15:15:22 EST
worth trying this again under 3.2.20 as a lot of unicode issues were fixed.
Comment 13 seth vidal 2009-01-21 14:13:05 EST
it is likely this has been fixed in 3.2.20 or beyond.

Note You need to log in before you can comment on or make changes to this bug.