Bug 448861 - gnome-settings-daemon has been downgraded incorrectly
gnome-settings-daemon has been downgraded incorrectly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 00:05 EDT by petrosyan
Modified: 2016-09-19 22:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 14:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2008-05-29 00:05:08 EDT
Description of problem:
On 2008-05-21 gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 was released as a
Fedora update.

On 2008-05-28 gnome-settings-daemon-2.22.1-1.2008.03.26.7.fc9 was released as a
Fedora update *and* gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 was deleted
from Fedora updates repository.

Obviously 2008-05-28 did not downgrade my gnome-settings-daemon package. However
it made it an orphaned package, because that package is not present in any
Fedora repository any more.

Steps to Reproduce:
$ package-cleanup --orphans
  
Actual results:
gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9.x86_64

Expected results:
There should be no orphaned packages in Fedora. If you need to downgrade some
package release it with a higher version number, so that an upgrade takes place.
Comment 1 Bastien Nocera 2008-05-29 11:05:08 EDT
updates-testing allows that. Feel free to point us to documentation that says
otherwise...
Comment 2 Jesse Keating 2008-05-29 11:13:31 EDT
I guess we don't have it written down anywhere, but builds are not to go
backwards.  We don't even do it in rawhide any more.
Comment 3 petrosyan 2008-05-29 12:23:26 EDT
I have never used updates-testing on my machine.

gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 was pushed as Fedora updates
*stable*, then gnome-settings-daemon-2.22.1-1.2008.03.26.7.fc9 was pushed as
Fedora updates *stable* and 03.26.8 was removed from updates *stable*.

So without ever using any updates-testing I ended up with an orphaned package.
Comment 4 Bastien Nocera 2008-05-30 11:36:35 EDT
It's a problem with bodhi. I saw those 2 mails being sent to me:

On the 20th of May:
Package: gnome-settings-daemon
NVR: gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9
User: lmacken
Status: complete
Tag Operation: moved
From Tag: dist-f9-updates-testing
Into Tag: dist-f9-updates

gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 successfully moved from
dist-f9-updates-testing into dist-f9-updates by lmacken

And then on Tuesday:
Package: gnome-settings-daemon
NVR: gnome-settings-daemon-2.22.1-1.2008.03.26.7.fc9
User: lmacken
Status: complete
Tag Operation: moved
From Tag: dist-f9-updates-testing
Into Tag: dist-f9-updates

gnome-settings-daemon-2.22.1-1.2008.03.26.7.fc9 successfully moved from
dist-f9-updates-testing into dist-f9-updates by lmacken

The second update should obviously not have been allowed to be pushed to stable,
and the scripts probably deleted any _other_ version of the package, instead of
just earlier ones.
Comment 5 Bill Nottingham 2008-05-30 11:56:41 EDT
Assigning to the bodhi maintainer, although this could probably be fixed by just
re-setting .8 to be pushed.
Comment 6 Luke Macken 2008-05-30 14:25:27 EDT
Yes, bodhi should have detected a broken update path when hadess submitted an
older update for pushing to stable.

I've since re-tagged gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9, and kicked
off a f9-updates mash -- so this should be going back out shortly.

I just committed a change to bodhi that will check for broken update paths when
requesting an update be pushed to 'stable'.  I also wrote a couple of unit tests
for this as well.

https://fedorahosted.org/bodhi/changeset/eb8d75733856ab608f0de6805a87c84af2c753eb

Note You need to log in before you can comment on or make changes to this bug.