Bug 448865 - NetworkManager disable quagga routing daemons
NetworkManager disable quagga routing daemons
Status: CLOSED DUPLICATE of bug 451625
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 00:49 EDT by Răzvan Sandu
Modified: 2008-06-22 07:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-22 07:21:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-05-29 00:49:44 EDT
Description of problem:

On a system upgraded from F8 to F9, when switching from system-config-network to
NetworkManager, system stops learning routes via ripd.


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.3.svn3669.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Install F8 + all online updates (as of May 29th, 2008)
2. Use system-config-network (static networking) for Ethernet connection
3. Configure workstation to (passively) learn routes via ripd and zebra
4. Upgrade to F9 (using official F9 DVD)
5. Test that the workstation learns routes via ripd for an unlimited period of time
6. Configure Ethernet interface to use NetworkManager by marking "Controlled by
NetworkManager" in System -> Administration -> Network
7. Start NetworkManager daemon and stop network daemon

  
Actual results:
After a while, despite network is active, the workstation is accessible remotely
via its default gateway *only*, since it ceased to learn routes through RIP.

If one restarts ripd and zebra manually, they work OK afterwards.


Expected results:
ripd and zebra should become active at boot and *remain so*, learning rip routes
and providing full network connectivity.


Additional info:
Comment 1 Răzvan Sandu 2008-06-22 07:21:01 EDT

*** This bug has been marked as a duplicate of 451625 ***

Note You need to log in before you can comment on or make changes to this bug.