Bug 448872 - Can't display the installation interface after X server starts successfully
Can't display the installation interface after X server starts successfully
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 02:45 EDT by Xu Bo
Modified: 2013-01-10 16:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 17:02:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xu Bo 2008-05-29 02:45:24 EDT
Description of problem:

I got a laptop which model is "HP Compaq 8510p RM269UT#ABA", chipset is Intel
PM965/GM965/GL960 series, video controller is “ATI M76 [Radeon Mobility HD 2600
Series], loaded driver is radeon_tp. The LCD is WSXGA+ (1680X1050).

After booting from RHEL5.2 installation media then skipping the “media test”,
anaconda started, and the video controller “ATI M76 [Radeon Mobility HD 2600
Series] was detected. After that the screen got black. Looks like it doesn't
work even though I used “linux resolution=800x600” or “linux noprobe” option to
start the installation.

But if I use a external monitor connecting to the output VGA port on the laptop,
everything looks well on the monitor except the screen of laotop is black.

Another way to work around this issue is to install in text mode. After
finishing the installation, we need to edit “/etc/inittab” and change the mode
from 3 to 5 and then restart the system.

BTW, I tried to install Fedora 9 and didn't met this issue. Everything looked good.

Version-Release number of selected component (if applicable): 

xorg-X11-server-Xorg-1.1.1-48.41.el5

How reproducible:
Always on i386 & x86_64 arch.
Comment 2 David Aquilina 2008-06-04 14:57:57 EDT
I have an HP 8510p laptop with the same chipset. When anaconda tries to start X,
the screen looks like: 

http://people.redhat.com/dwa/radeon-tp.jpg

If we force anaconda to use VESA ('xdriver=vesa' on the kernel boot line), it
works fine. 
Comment 3 Xu Bo 2008-06-04 21:59:43 EDT
DWA, howdy,

I am going to following your advice and get VIDEO test run to figure out whether
it can supports up to 1680X1050 resolution. 

Next time, I should pay more attention to the "Technology Preview features". I
have not known those features would affect our certification before :(

Thanks for your updates, I will upload the test results ASAP.
/Xu
Comment 4 Matěj Cepl 2008-06-06 11:34:15 EDT
Just to mark here that we are waiting on your input, marking this bug as NEEDINFO.
Comment 5 David Aquilina 2008-06-06 11:39:23 EDT
(In reply to comment #4)
> Just to mark here that we are waiting on your input, marking this bug as NEEDINFO.

Which information are you waiting for? The test results Xu refers to are for
hardware certification of the laptop we've seen this issue on. 

I've already verified that the vesa driver works on this laptop. Is there some
other testing you'd like performed? I have a sample of the system in the
Westford office. 
Comment 6 Matěj Cepl 2008-06-06 18:17:21 EDT
No, sorry.
Comment 7 Xu Bo 2008-06-11 03:19:01 EDT
Have uploaded the test results (using xdriver=vesa to install the OS) on
cert#448504. Please refer to the comments in it.
Comment 8 Adam Jackson 2012-04-17 17:02:13 EDT
No further hardware enablement updates are planned for RHEL5's X stack.  If this issue is still present in RHEL6, please update the affected product version and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.