Bug 448878 - Keyboard layout is not the expected one at install
Keyboard layout is not the expected one at install
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-29 04:01 EDT by Thibault North
Modified: 2008-06-09 16:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-09 16:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thibault North 2008-05-29 04:01:10 EDT
Description of problem:
When installing F9 in English with a keyboard like Swiss French, the keymap at
install time is not the good one. 
This means that you choose a root password with a bad keymap, and cannot login
as root after the installation has succeeded.

Version-Release number of selected component:

Steps to Reproduce:
1. Install F9 from the DVD with english langage
2. Choose a Swiss French keymap
3. Set your root password and finish the install
4. Reboot and try to login as root.
Actual results:
Cannot login as root

Expected results:
Ability to login

Additional info:
Need to change the root password by rebooting with the "linux single" option
Comment 1 Andy Lindeberg 2008-05-29 21:24:40 EDT
I was unable to reproduce this error with testing. The root password contained
letters that changed between QWERTY and fr_CA layouts, and worked on the first
try when logging in as root.

Are you sure you didn't make an unintended typo when either logging in as root
or when setting the password at the start?
Comment 2 Thibault North 2008-06-04 05:29:20 EDT
I tried again with a freshly downloaded F-9 DVD.
- Set langage to English
- Set keymap to Swiss French (fr_CH)

At install stage, the keymap seems to be a *French* layout (FR_fr), which is
*very* different of the Swiss French one.

Consequences :
- The root password was set as if I used a French keyboard => no ability to log
in as root.
- The user password was also set with a French keyboard => no ability to log as
user. (here, when setting the Full name, we can often see that the keymap
doesn't match)

Please try and reproduce this error with the same keymap (fr_CH) and not a fr_CA
one !
Please also reconsider high severity for this bug : you'll lose a lot of Swiss
French users.
Comment 3 Andy Lindeberg 2008-06-04 09:34:36 EDT
Apologies, I made a typo in my response. The layout I used was fr_CH, not fr_CA.

I tried again, this time setting root password as the entire lowercase alphabet
to ensure there would be something that would change between keyboard layouts,
since I'm unfamiliar with Swiss French and French keyboards.

I noticed when setting Hostname, the keyboard was still in a qwerty layout.

When I went to set the user name, the changes I noticed were that a on querty is
q on fr_CH and vice versa, z and w are switched, and qwerty 'm' = ',', qwerty
',' = ';', and querty ';' = 'm'.

This time, I was unable to login as root or as user, although I used the same
user password as I had the first time.

Comment 4 Andy Lindeberg 2008-06-04 09:39:50 EDT
Also: When logging in as root, when typing "root" the keyboard is in a qwerty
layout and NOT in either french OR swiss french.

Do you happen to know the french and swiss french layouts? I'd like to look some
more into what is and isn't properly changed.
Comment 5 Thibault North 2008-06-04 09:51:25 EDT
>Do you happen to know the french and swiss french layouts? I'd like to look some
>more into what is and isn't properly changed.

Is that what you mean ?
Comment 6 Andy Lindeberg 2008-06-05 10:11:09 EDT
Yep, and it does indeed seem to be using the french keyboard and not swiss french.
Comment 7 Chris Lumens 2008-06-09 16:51:01 EDT
This will be fixed in the next build of rhpl.

Note You need to log in before you can comment on or make changes to this bug.