Bug 448931 - Remove rhmd script and just use qpidd
Remove rhmd script and just use qpidd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity low
: ---
: ---
Assigned To: Lana Brindley
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 11:17 EDT by Gordon Sim
Modified: 2013-10-23 19:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 19:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-05-29 11:17:23 EDT
* rhmd script can be removed (from /usr/sbin and /etc/initd)
* bdbstore module will be installed into the default module directory
* all documentation should be updated accordingly
Comment 1 Nuno Santos 2008-05-29 18:41:26 EDT
As of svn rev 2093, /etc/init.d/rhmd initscript and /usr/bin/rhmd startup script
have been removed, and the module is being installed under /usr/lib/qpidd.

These changes need to be documented, so I'm assigning to Lana.
Comment 2 Carl Trieloff 2008-05-30 11:57:18 EDT
Nuno, can you read few pages that are affected and add what needs to be changed
in the guide for Lana. Remember she was not part of the call we had discussing
it, so context will help her on the doc
Comment 3 Nuno Santos 2008-06-02 14:05:20 EDT
I went through the Installation Guide, searched for rhmd and found several
instances where it needs to be replaced by qpidd:

- pg.12: these files are no longer installed: /etc/rc.d/init.d/rhmd ,
/etc/rc.d/init.d/rhmd

- pg.12: the install location for these files has changed:
/usr/lib/libbdbstore.so.0, /usr/lib/libbdbstore.so.0.1.0 , they're now under
/usr/lib/qpidd/

- pg.15: the broker is now started with /usr/sbin/qpidd , or "service qpidd
start"; (same for service status/stop)

-pg.17: replace rhmd with qpidd in the command lines; replace "service rhmd
restart" with "service qpidd restart"

-pg.18: replace rhmd with qpidd in the command lines, in the man command and in
the --help command


An important thing to note is that once the rhm package is installed, the store
will be automatically picked up by qpidd, since the lib is now dropped in the
"module auto load" (/usr/lib/qpidd) directory for qpidd. 

Let me know if you need more details.
Comment 4 Nuno Santos 2008-06-02 14:08:04 EDT
Similar changes need to be made to the Tutorial, namely on pages 19 and 20.

Btw, the page numbers above are all document-absolute (ie, page 19 is the 19th
page of the doc), they do not reflect page numbers on the footers.
Comment 5 Lana Brindley 2008-06-03 02:00:02 EDT
(In reply to comment #3)
> I went through the Installation Guide, searched for rhmd and found several
> instances where it needs to be replaced by qpidd:
> 
> - pg.12: these files are no longer installed: /etc/rc.d/init.d/rhmd ,
> /etc/rc.d/init.d/rhmd

Removed /etc/rc.d/init.d/rhmd and /usr/sbin/rhmd
(I hope that's what you meant...?)

> 
> - pg.12: the install location for these files has changed:
> /usr/lib/libbdbstore.so.0, /usr/lib/libbdbstore.so.0.1.0 , they're now under
> /usr/lib/qpidd/

Updated to:
/usr/lib/qpiddlibbdbstore.so.0
/usr/lib/qpidd/libbdbstore.so.0.1.0

> 
> - pg.15: the broker is now started with /usr/sbin/qpidd , or "service qpidd
> start"; (same for service status/stop)

Does the service still state:
Starting RHM daemon:     [  OK  ]

Updated to:
# /usr/sbin/qpidd -t
# service qpidd start
# service qpidd status
# service qpidd stop

> 
> -pg.17: replace rhmd with qpidd in the command lines; replace "service rhmd
> restart" with "service qpidd restart"

Is the name of the config file now /etc/qpidd.conf?

Changed:
# service qpidd restart
# /usr/sbin/qpidd -t
# /usr/sbin/qpidd -t --load-module <replaceable>libbdbstore.so</replaceable>
--log-output <replaceable>/var/log/qpidd.log</replaceable>


> 
> -pg.18: replace rhmd with qpidd in the command lines, in the man command and in
> the --help command
> 

Updated:
For more options, type <command># man qpidd</command> or <command>#
/usr/sbin/qpidd --help</command> at the shell prompt.

> 
> An important thing to note is that once the rhm package is installed, the store
> will be automatically picked up by qpidd, since the lib is now dropped in the
> "module auto load" (/usr/lib/qpidd) directory for qpidd. 

Does this require further changes? 

> 
> Let me know if you need more details.

Thanks Nuno ... anything further, just let me know.

LKB

Comment 7 Lana Brindley 2008-06-03 02:33:33 EDT
(In reply to comment #4)
> Similar changes need to be made to the Tutorial, namely on pages 19 and 20.

Adjusted:

# rpm -ql rhm
/etc/rhmd.conf
/usr/lib/qpiddlibbdbstore.so.0
/usr/lib/qpidd/libbdbstore.so.0.1.0
/usr/share/doc/rhm-0.2
/usr/share/doc/rhm-0.2/COPYING
/usr/share/doc/rhm-0.2/README
/var/rhm

# /usr/sbin/qpidd -t
[date] [time] info Loaded Module: libbdbstore.so.0
[date] [time] info Locked data directory: /var/lib/qpidd
[date] [time] info Management enabled
[date] [time] info Listening on port 5672

# service qpidd start
Starting RHM daemon:     [  OK  ]

# service qpidd status
qpidd (pid <replaceable>PID</replaceable>) is running...
				
# service qpidd stop
Stopping RHM daemon:     [  OK  ]


> 
> Btw, the page numbers above are all document-absolute (ie, page 19 is the 19th
> page of the doc), they do not reflect page numbers on the footers.
> 

Comment 8 Lana Brindley 2008-06-03 02:38:02 EDT
Tutorial available for review here:
https://engineering.redhat.com/docbot/en-US/Red_Hat_Enterprise_MRG/1.0/html/Messaging_Tutorial/

LKB
Comment 9 Nuno Santos 2008-06-03 14:01:09 EDT
The tutorial at that link doesn't seem to have been updated.

Also, don't forget to rename RHM to qpidd in "starting/stopping RHM daemon" above.

Nuno
Comment 10 Lana Brindley 2008-06-03 19:13:37 EDT
(In reply to comment #9)
> The tutorial at that link doesn't seem to have been updated.

My bad - it should be good now.

> 
> Also, don't forget to rename RHM to qpidd in "starting/stopping RHM daemon" above.

Done :)

LKB

Note You need to log in before you can comment on or make changes to this bug.